1

Not sure this fits in here..

We recently installed Linux Mint Petra on this small-form-factor dell desktop.

The weird thing is, the sound does not work on board, but works on a speaker connected to the audio out. I've checked all details I could about the alsa mixer, sound card mute check etc. All seems fine. Also looked to see if the box had any mute on/off button but there's none in sight.

Previously, when the box had Windows XP, there indeed was on-board sound, and thus there was no need to use external speakers for the audio.

Has anyone come across this issue, or is there anything else I could check. Any online search result only talks about general sound-card issues, but this is specifically a case of onboard sound not working.

Of course one could say why not just plug in speakers, but I would like to understand what the problem might be here and find a solution.

This question was seen as not relevant in the ubuntu forum when originally posted there.

$ cat /proc/asound/cards
 0 [ICH6 ]: ICH4 - Intel ICH6
            Intel ICH6 with AD1981B at irq 23

$ sudo lshw
     *-multimedia
    description: Multimedia audio controller
    product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
    vendor: Intel Corporation
    physical id: 1e.2
    bus info: pci@0000:00:1e.2
    version: 03
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list
    configuration: driver=snd_intel8x0 latency=0
    resources: irq:23 ioport:ec00(size=256) ioport:e8c0(size=64) memory:dfebfe00-dfebffff memory

 

$ lsmod | grep pcspkr
pcspkr 12630 0

$ lsmod | grep snd  
snd_intel8x0 33069 3
snd_ac97_codec 105668 1 snd_intel8x0
ac97_bus 12642 1 snd_ac97_codec
snd_pcm 89488 3 snd_ac97_codec,snd_intel8x0
snd_page_alloc 14230 2 snd_intel8x0,snd_pcm
snd_seq_midi 13132 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_rawmidi 25094 1 snd_seq_midi
snd_seq 55383 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 14137 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 24447 2 snd_pcm,snd_seq
snd 60790 13   snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device,snd_seq_midi
soundcore 12600 1 snd
  • Shot in the dark, does running sudo modprobe pcspkr make any difference? – terdon Feb 2 '14 at 20:03
  • No joy, unfortunately :-( Would you expect that command to give any output when run? It said nothing when I executed it. I even tried -v and --verbose. The manual says modprobe usually only prints messages if something goes wrong. – Å Stuart Feb 2 '14 at 21:50
  • That should load the relevant module, try using the soundcard after running that command. – terdon Feb 2 '14 at 22:34
  • By try using the soundcard if you meant play something with sound, yes, that's precisely what I tried right after running the command. – Å Stuart Feb 3 '14 at 16:35
  • Hmm, OK on my system that's the module that lets the machine beep at me, I was hoping that loading that would fix your issues. The modprobe command should give no output but you can check if the module was correctly loaded with lsmod | grep pcspkr. Your card is associated with the snd_intel8x0 dirver, could you post the output of lsmod | grep snd? – terdon Feb 3 '14 at 18:12
1

I installed gnome-alsamixer and when I opened it and it had some set to be mute. Unmute the Master M and sound works!

One hitch though, when I restart it goes back to mute format, I'll update this answer if I find a fix for that. But I guess it's not as bad as no sound at all.

0

command-line solution:

alsamixer

Master, Master M, Headphone and PCM have to be unmuted ('M' toggles on/off)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.