0

This question already has an answer here:

I have RaspberryPI with no GUI==(no x.org) I like to bind the useless window/super key to be my prefix. Using Arch for ARM runs great.

If think this is going to take more then simple mod in the tmux.conf file.

After some Googling found post with a command: dumpkeys | grep -E "keycode *125|126" That command give me a blank line.

marked as duplicate by Gilles, jasonwryan, slm, rahmu, vonbrand Feb 3 '14 at 1:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Their is no X running on the system. – saras Feb 8 '14 at 21:25
  • I know a the top tell me question has been answered but in fact none of the answer on the question work without X. – saras Feb 8 '14 at 21:31
  • Using showkey i got 125 as keycode when i hit the meta key on my machine. Created a file with content 'keycode 125 = Control_b', added it the the keymap with loadkeys, launched tmux (default config) and it works. – fins Apr 7 '17 at 1:36
1

put this in your ~/.tmux.conf file:

1  ### command prefix 
2  unbind C-b
3  set-option -g prefix Super_L

If it's not working, check your xterm settings, environment variable(s). Can you run xev to check what it says when you press the key? Sorry, I hadn't seen the last part of the question at first :p

Also, check out this linuxforums thread for some more information on keybindings, and the programs xmodmap and xbindkeys

Not the answer you're looking for? Browse other questions tagged or ask your own question.