I've got an AMD Radeon HD 6950 card:

$ lspci | grep AMD
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cayman PRO [Radeon HD 6950]
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cayman/Antilles HDMI Audio [Radeon HD 6900 Series]

HDMI audio is supported on kernel 3.5 and higher, which I have:

$ uname -r

I've installed the latest version of the (hopefully) relevant packages:

  • alsa-lib
  • alsa-plugins 1.0.27-2
  • alsa-utils
  • ati-dri 10.0.2-1
  • lib32-alsa-lib
  • lib32-ati-dri 10.0.2-1
  • xf86-video-ati 1:7.3.0-1

ALSA detects the sound card:

$ aplay -l | grep HDMI
card 2: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]

I've enabled the kernel module:

$ sudo grep -F radeon.audio /boot/grub/grub.cfg
    linux /boot/vmlinuz-linux root=UUID=... rw  quiet radeon.audio=1
    linux /boot/vmlinuz-linux root=UUID=... rw  quiet radeon.audio=1
        linux   /boot/vmlinuz-linux root=UUID=... rw  quiet radeon.audio=1
                linux   /boot/vmlinuz-linux root=UUID=... rw  quiet radeon.audio=1

I've enabled the only channel that is available for the card:

$ amixer --card 2 
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

However, my receiver insists there is no signal when I try to play something:

$ speaker-test --device plughw:2,3


Playback device is plughw:2,3
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 1048576
Period size range from 32 to 524288
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
Time per period = 5.473506

I also tried changing from S/PDIF output (which works) to HDMI in VLC, with the same result - the player doesn't complain, the receiver detects that it's connected via HDMI, but it insists there is no signal.

And finally, I tried rebooting after writing this up. No changes.

Is ALSA correctly detecting the card? Do I need any other packages? Other kernel settings?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.