I have a fresh, text-only installation of openSuSe 13.1 (physical server, old Samsung netbook), and I'm trying to get OTRS up and running. I've installed OTRS using the below commands. I don't think they're all necessary, but someone in the OtterHub forums had a successful installation with the software versions I'm targeting using this sequence, so I was trying to piggyback on that success.

zypper in otrs-3.3.4-01.noarch.rpm gcc make mysql-community-server perl-Crypt-SSLeay perl-JSON-XS perl-YAML-LibYAML
zypper in perl-Text-CSV_XS perl-PDF-API2 perl-GDGraph perl-Encode-HanExtra postfix perl-DBD-mysql
cd ~otrs && bin/otrs.SetPermissions.pl --otrs-user=otrs --web-user=wwwrun --otrs-group=www --web-group=www /opt/otrs
rcmysql start
systemctl start apache2.service
mysqladmin --user=root password password

All of that works fine. I'm able to get to the OTRS web installer, but that's where I get hung up. I get to the part of the web installer that creates the database, and it times out. The script successfully creates the database and updates Config.pm with the new password. I can't tell from installer.pl what it tries to do next.

Here's the error from /var/log/apache2/error_log:

[Tue Jan 28 20:53:23.136306 2014] [cgi:warn] [pid 6856] [client] AH01220: Timeout waiting for output from CGI script /opt/otrs/bin/cgi-bin/installer.pl, referer: http://svr-clptest/otrs/installer.pl
[Tue Jan 28 20:53:23.136470 2014] [cgi:error] [pid 6856] [client] Script timed out before returning headers: installer.pl, referer: http://svr-clptest/otrs/installer.pl

The browser displays the following:

The gateway did not receive a timely response from the upstream server or application.

This is on a local network at home. I'm accessing the Linux server using PuTTY from a Windows 8 machine. I'm using a wireless connection from the Windows 8 machine, but the server has a hard line connection to the router, if that makes any difference. I don't have any trouble executing anything from PuTTY or accessing the index page through the browser (Firefox 26). I've tried connecting from a computer on my network, and one off of my network. In both cases, I'm able to get to my domain and the web installer. But I can't make a PuTTY connection to the server from outside my network.

I've spent a couple of hours researching the error, and I can't figure out what the next step should be.

Right now, a text-only version of openSUSE and OTRS are the only things running on the machine. I haven't done anything else with it. I'm open to starting the installation from scratch again--OS and all. I'm thinking that the timeout error has something to do with my firewall settings, but I'm not a network guy. Really have no idea how to diagnose this.


I tried reinstalling everything fresh tonight, but then added KDE so I could walk through the web installer on the host. I get exactly the same errors. It's not a problem between server and client. Something's wrong with OTRS... Or maybe with apache?


I may have found a catch-22 here. Following crythias' instructions (post here: http://forums.otterhub.org/viewtopic.php?f=63&t=23757), I noticed that the OTRS service wouldn't start. The error indicated that otrs couldn't connect to the database. Of course it can't, because the OTRS database hasn't been created yet. So the error also suggests using the web installer to set up the database.

I run the web installer, get the same error in the same place. But now that the database is created, the OTRS service starts. The problem is, now I can't complete the installer because the database already exists. If I try to create a new database, it tells me 'otrs' already exists. If I try to use the existing database, it tells me 'Database already contains data - it should be empty!' If I use an empty database called 'otrs,' my OTRS error log spits out the following:

[Fri Jan 31 20:45:01 2014][Error][Kernel::System::PID::PIDGet][181] Table 'otrs.process_id' doesn't exist, SQL: ' SELECT process_name, process_id, process_host, process_create, process_change FROM process_id WHERE process_name = ? LIMIT 1'
[Fri Jan 31 20:45:32 2014][Error][/opt/otrs/bin/otrs.CheckDB.pl][57] Table 'otrs.valid' doesn't exist, SQL: 'SELECT * FROM valid'

If I start the service, then delete the database, the service immediately spits out an error

[Fri Jan 31 21:05:38 2014][Error][Kernel::System::PID::PIDGet][181] Table 'otrs.process_id' doesn't exist, SQL: ' SELECT process_name, process_id, process_host, process_create, process_change FROM process_id WHERE process_name = ? LIMIT 1'
[Fri Jan 31 21:05:38 2014][Error][Kernel::System::DB::new][223] Unknown database 'otrs'

If the OTRS service is supposed to be started before I run the web installer, but the service won't start until the database is created, I think I'm stuck.

  • 1
    Set $Self->{'Debug'} = 1;, $Self->{'LogModule::LogFile'} = '/var/log/otrs.log'; and $Self->{'LogModule'} = 'Kernel::System::Log::File'; in your Kernel/Config.pm before starting the installer. Then check /var/log/otrs.log for a more detailed error and paste the relevant lines. Jan 31, 2014 at 14:27
  • Thanks for the tip @EliasProbst. I've updated the info above.
    – tmoore82
    Feb 1, 2014 at 2:16

1 Answer 1


Still not exactly sure what the error was with the web installer, but I was able to overcome the problem by deleting the existing OTRS database and following the instructions for manual database configuration found in the OTRS admin guide (http://doc.otrs.org/3.0/en/html/manual-installation-of-otrs.html). After doing the manual configuration, setting up the cron jobs, and restarting the otrs service, I was able to log into localhost/otrs/index.pl using the default root credentials. Still not sure what was wrong with the web installer, but everything is up and running now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .