2

I am trying to Read / Write data into my HP LTO3 1X8 Autoloader Tape drive. I have the required drivers installed.

When I ran rpm -qa | grep mt-st I got:

mt-st-1.1-5.el6.x86_64

Further when I ran cat /proc/scsi/scsi I got:

Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: NECVMWar Model: VMware IDE CDR10 Rev: 1.00
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: VMware   Model: Virtual disk     Rev: 1.0
  Type:   Direct-Access                    ANSI  SCSI revision: 02
Host: scsi2 Channel: 00 Id: 01 Lun: 00
  Vendor: HP       Model: 1x8 autoloader   Rev: 1.50
  Type:   Medium Changer                   ANSI  SCSI revision: 03

Further tapeinfo -f /dev/sg2:

Product Type: Medium Changer
Vendor ID: 'HP      '
Product ID: '1x8 autoloader  '
Revision: '1.50'
Attached Changer API: No
SerialNumber: 'MXA0633052'
SCSI ID: 1
SCSI LUN: 0
Ready: yes

There is no device file st0 in my /dev location. So I tried to make it by some references from internet.

I ran mknod /dev/st0 c 9 0, but when I use mt command

mt -f /dev/st0 status

/dev/st0: No such device or address

Please point me in right direction

3
+50

Vendor: VMware Model: Virtual disk says you're running a VM. As such, it is entirely possible you aren't seeing the tape device because it isn't exported to your VM. You have the library mapped, but not the drive within it -- which is a free-standing SCSI device.

(or, perhaps your library is missing its drive???)

  • In my base system it is vmware and VM mounted on it is running centOS – Shadow Feb 7 '14 at 5:19
0

When you look at the dmesg output for this device you should be directed to a device. From the docs that @yoonix referenced in comments:

autoloader

$ dmesg | grep -A 2 "1x8 G2 AUTOLDR"    
Vendor: HP Model: 1x8 G2 AUTOLDR  
Rev: kn7B nl  Type:  
Medium Changer ANSI SCSI revision: 03 nl  3:0:0:0:  
Attached scsi generic sg2 type 8 

tape

$ dmesg | grep -A 4 "Ultrium"
Vendor: HP Model: Ultrium 3-SCSI  
Rev: kn7B    
Type: Sequential-Access ANSI SCSI revision: 03  
4:0:0:0: Attached scsi generic sg2 type 1    
st: version 20050830, fixed bufsize 32768, s/g segs 256    
st 4:0:0:0: Attached scsi tape st0 

Since you're accessing the autoloader on /dev/sg2 I would try this command to confirm the tape is being identified:

$ mtx -f /dev/sg2 status
Storage Changer /dev/sg2:1 Drives, 9 Slots ( 1 Import/Export )    
Data Transfer Element 0:Empty   
Storage Element 1:Full :VolumeTag=64258F41    
Storage Element 2:Full :VolumeTag=64258F42    
Storage Element 3:Full :VolumeTag=64258F43    
Storage Element 4:Full :VolumeTag=64258F44    
Storage Element 5:Full :VolumeTag=64258F45    
Storage Element 6:Empty    
Storage Element 7:Empty   
Storage Element 8:Empty    
Storage Element 9 IMPORT/EXPORT:Empty   

But it should likely be whatever handle is mentioned in the output from dmesg.

hwinfo

You could also run this command, hwinfo to get more info about the tape drive.

$ hwinfo --tape
89: SCSI 00.0: 10601 Tape
[Created at scsi.1460]
UDI: /org/freedesktop/Hal/devices/pci_103c_323a_scsi_host_scsi_device_lun0_scsi_gene ric
Unique ID: Er1e.jH5QXkQpQf6
Parent ID: GBI1.XEXEELn_ra7
SysFS ID: /class/scsi_tape/st0
SysFS BusID: 0:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:03.0/0000:08:00.0/host0/target0:0:0/0:0:0:0
Hardware Class: unknown
Model: "HP Ultrium 4-SCSI"
Vendor: "HP"
Device: "Ultrium 4-SCSI"
Revision: "U57D"
Driver: "cciss", "st"
Driver Modules: "cciss"
Device File: /dev/st0 (/dev/sg0)
Device Files: /dev/st0, /dev/char/9:0, /dev/tape/by-id/scsi-3500110a001465016, /dev/tape/by-path/pci-0000:08:00.0-scsi-0:0:0:0
Device Number: char 9:0 (char 21:0)
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #61 (RAID bus controller)mt command out puts

Source: https://forums.suse.com/archive/index.php/t-1510.html

  • I ran those commands you mentioned, but non of them returned me anything,except mtx -f /dev/sg2 status – Shadow Feb 3 '14 at 5:13
  • @shadow - has the system been rebooted recently or been up for a long time? The contents of dmesg get's dropped over time, so to really confirm those commands a reboot would be needed. – slm Feb 3 '14 at 5:17
  • @sim ya, we rebooted it 3 days before – Shadow Feb 3 '14 at 5:18
  • @shadow - there was no mention of any of the tape devices in dmesg. Perhaps the pattern I'm telling you to grep for is incorrect for your particular hardware. If nothing is showing up there, then that tells me that the Linux kernel is not detecting this hardware correctly. I would also take a look in your system's BIOS for potential leads too. – slm Feb 3 '14 at 5:23
  • When i ran mtx -f /dev/sg2 status it showed me different storage elements – Shadow Feb 3 '14 at 5:25
0

Not sure how this specific device works, but if this is an autoloader/jukebox, wouldn't the jukebox have a scsi address AND the tape drive another one?

It looks like you have mapped the jukebox as a raw device into the VM. Have you done the same thing for the tape drive?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.