56

I need to execute rsync, without it prompting me for password.

I've seen in rsync manpage that it doesn't allow specifying the password as command line argument.
But I noticed that it allows specifying the password via the variable RSYNC_PASSWORD.

So I've tried exporting the variable, but rsync keeps asking me for password.

export RSYNC_PASSWORD="abcdef"
rsync root@1.2.3.4:/abc /def

What am I doing wrong?

Please consider:

In other words, I need to have the RSYNC_PASSWORD approach working! :-)

  • have you enable rsync daemon on remote server ? – Rahul Patil Jan 29 '14 at 19:41
  • Not always an option, but one can use the mirror option with lftp to do this over SFTP. See here – Sean Breckenridge Jun 29 at 4:51
13

This password environment variable appears only to be used when using the rsync protocol:

rsync rsync://username@1.2.3.4:/abc /def

For this to work, you need to run rsync as a daemon as well (--daemon option), which is often done using inetd.conf.

When using this protocol, abc should correspond to a target defined in /etc/rsyncd.conf. The user name should be present in a auth users line for this target, and a password file should be specified with the secrets file option.

It is this secrets file that contains mappings between user names and passwords in the following format:

username:password

And it is this password that you can specify using the RSYNC_PASSWORD environment variable.

| improve this answer | |
78

If the rsync daemon isn't running on the target machine, and you don't care about exposing passwords to everyone on the local machine (Why shouldn't someone use passwords in the command line?), you can use sshpass:

 sshpass -p "password" rsync root@1.2.3.4:/abc /def

Note the space at the start of the command, in the bash shell this will stop the command (and the password) from being stored in the history. I don't recommend using the RSYNC_PASSWORD variable unless absolutely necessary (as per a previous edit to this answer), I recommend suppressing history storage or at least clearing history after. In addition, you can use tput reset to clear your terminal history.

| improve this answer | |
  • 2
    Why would you suggest adding password clear text on a command, that's bad linux admin 101. – Eddie Mar 22 '15 at 12:34
  • Super handy.. been searching for an approach to this for a while. Thank you. – Isaac Gregson Feb 26 '16 at 18:55
  • 6
    While this is bad to add the password as clear text, this is currently the only reasonably simple way to this. – Weston Ganger Jun 24 '16 at 16:34
  • 19
    you can always do something like this: sshpass -p $(cat passFile) .. to hide clear pass in bash history,, and chmod 400 on passFile to secure it – Kresimir Pendic Jan 2 '17 at 16:27
  • 4
    I know that this is old, but for the sake of newer readers, please quote the password — passwords can contain special characters and spaces. -p "$RSYNC_PASSWORD" – Paddy Landau Jul 14 '18 at 15:54
17

You can use standard ssh identities to do passwordless login. This is handled by default if you have a ~/.ssh/id_rsa or the like, but you can also hardcode your own path to the private key of an authorized keypair.

This allows batching/scripting without exposing passwords, and the public key can be remove from the target server if the private key is ever compromised.

rsync -e"ssh -i /path/to/privateKey" -avR $sourcedir ${ruser}@${rhost}:~/${rdir}/

You can also add arguments like -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null to not force remote host key verification. !Caution - that opens up man in the middle attacks and is general bad practice!

| improve this answer | |
  • 1
    This is especially useful if you're using the new Bash shell for Windows 10. I was wondering why rsync wasn't working passwordlessly. I realized it was using the ~/.ssh folder inside the shell (where rsync lives). Once I used -e to point to the key inside /mnt/c/Users/MyUsername/.ssh, it worked as expected. (Thanks. :D) – Toby Deshane Oct 25 '16 at 14:06
14

Very useful for scripting is to use --password-file command line option.

  • Create empty file called rsync_pass
  • write in password to this file (nothing more)
  • chmod 600 rsync_pass
  • rsync $args --password-file=rsync_pass user@rsynchost::/share localdirectory

This can be used for scripting and allows to be more secure that just exporting password to system variable.

| improve this answer | |
  • 8
    Note to reader: this also requires an rsync daemon running on the server. I really was hoping that ssh keys would be sufficient for passwordless rsync. – Sridhar Sarnobat Nov 2 '15 at 7:01
  • 1
    IMHO this is the only correct way to do it if one doesn't want to use ssh. – maxf130 May 8 '16 at 9:51
  • You can use SSH keys. I have done this on my systems. You put the authorized key in the .ssh folder on the side you are trying to ssh to. In my case it is /root/.ssh/authorized_keys and on the side running the rsync command use the -e parameter to specify the ssh settings. In my case it is -e "ssh -i /path/to/ssh-key" for example. – Glenn J. Schworak Dec 26 '19 at 22:37
  • The main point was using rsyncd directly, thus ssh key doesn't play a role. It was stated in question 'without using public key authentication' – Arunas Bartisius Dec 28 '19 at 20:19
0

I wrote my script inspired by the comments in this post, so I'll post it here as another source of inspiration. My requirements were, no rsyncd on remote, password login, no exposure of password in history or command line. That's actually not very difficult:

#!/bin/bash

HOST=mymachine.mydomain.com
USER=fms
LOCAL=/home/fms/Progetti/MyProject/src

read -s -p "Password for $USER@$HOST: " SSHPASS
echo

sshpass -e rsync -i -r --checksum --delete --chown=nginx:nginx -e "ssh -o PreferredAuthentications=password" $LOCAL/lavori_senato $USER@$HOST:/var/www/drupal/test/web/modules/custom

I needed to alter the default configuration of my ssh so that it wouldn't try public-key first. The echo after read is just a touch of formatting, since using -s even the end of line is not printed, and the output of rsync overlapped with the password prompt.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.