3

I use the Terminator terminal emulator, and out of pure boredom, I installed and attempted to run this program: https://github.com/thiderman/doge.

However, it requires UTF-8 encoding to work. I opened Terminator's preferences and went into the default profile's compatibility tab, and it was already set to UTF-8.

I don't use any custom profiles.

The output of locale charmap # UTF-8 was ANSI_X3.4-1968. How can I make this work properly? I did test in UXterm, and it ran fine.

I'm running Arch Linux using the GNOME 3 GUI.

The output of locale -a is:

$ locale -a
C
POSIX
en_US
en_US.iso88591
en_US.utf8

It seems like I have a locale setting called "C", and I can't seem to bring UTF-8 to the top.

  • I can confirm that it works in terminator. Please post the output of locale -a. – terdon Jan 29 '14 at 5:05
  • Made an edit with this information. – 2mac Jan 29 '14 at 5:58
3

I still want to know why my locale settings got so weird after only enabling the en_US locales during installation, but I was able to resolve the issue by adding

export LC_ALL=en_US.UTF-8
export LANG=en_us.UTF-8

to my ~/.bashrc

  • 1
    The locale setting you need is LC_CTYPE. So make that export LC_CTYPE=en_US.UTF-8. I'm surprised that Terminator isn't doing it automatically: that should be its job. – Gilles Jan 29 '14 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.