2

I'm trying to debug the kernel. But I couldn't trigger kgdb with echo g > /proc/sysrq-trigger, it just prints help message.

enter image description here

I have enabled kernel debugging, kgdb over serial, frame pointer etc.

CONFIG_DEBUG_KERNEL=y
CONFIG_FRAME_POINTER=y
CONFIG_HAVE_ARCH_KGDB=y
CONFIG_KGDB=y
CONFIG_KGDB_SERIAL_CONSOLE=y

What could be missing? The kernel version is 2.6.32.1, running CentOS 5 in KVM

1

Looks like setting kgdboc parameters in boot options worked, not sure why.

(I'm using libvirtd)

  • I had the same problem -- it turned out to be an error in extlinux.conf which caused the kgdboc boot option to not be passed. – Alex D Feb 25 '15 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.