3

I've just switched from KDE to lightweight slim+xmonad environment and my fonts are not rendering correctly.

  1. I use DejaVu font family (default for Debian 7.x) which supports all characters I need (Proof: I've looked up these characters in gucharmap + in "konsole" app)

  2. I use rxvt-unicode as terminal, with fonts set in .Xresources. "konsole" app (opened directly in xmonad) shows all characters properly. Both urxvt and konsole are set to use DejaVu Sans.

  3. Even google-chrome behaves strangly. Obviously it uses different font for interface and for webpage, but even when I force DejaVu Sans as webpage font (through CSS), it doesn't help. google

  4. Lot of other unicode characters works. The one on screenshot is from Korean hangul -- could it be related to asian fonts?

2

Since two missing characters were korean ones, I installed set of asian fonts based on recommendation from Wikipedia:

sudo apt-get install ttf-arphic-uming ttf-wqy-zenhei fonts-ipafont-mincho fonts-ipafont-gothic ttf-unfonts-core

It does solved problems, both in GUI and console. However, few questions remains:

  • Why this problem occured when I switched desktop environment? Everything worked fine in KDE, until I began using plain xmonad (slim+xinitrc+xmonad).
  • Why gucharmap showed me all characters are present even before installing asian fonts?
1

The "missing characters" are most probably just character (really code points in Unicode speak) for which the font(s) configured don't have corresponding glyphs (i.e., pictures to draw). Many fonts are missing glyphs (the number of code points in Unicode is truly staggering).

It is probably best for all involved if you report it as a Debian bug. Any hep we could give here will be less knowledgeable than the one the developers/users can give you, and we aren't in position to fix it upstream either.

  • I don't want to fill Debian bug, because it seems to be just wrong configuration. In one DE everything works, in another it's broken. Either KDE does some additional configuration in background or I've done something wrong. – Tomáš Ehrlich Feb 5 '14 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.