2

I have installed the plugin correctly, but every time I try and start it either using service transmission start, or trying to flip the on switch from the plugins page, I get this error:

            ss

I also have tried creating a new standard jail and using portsnap to get transmission, but same error.

1

Lead #1

It would seem to be something that you have to configure through the Web GUI in FreeNAS. From the sound of this blog post titled: "Freenas 9.2.0 with Transmission and Couchpotato/Sickbeard as a DLNA-Server" you need to make changes through several GUIs in order to configure/enable Transmission so that it will work correctly.

             ss #1

That blog post goes on to caution you if you're using Transmission in a jail.

excerpt

The "watch"-directory where Transmission looks for torrent-files is normally:

   /usr/pbi/transmission-amd64/etc/transmission/Downloads

That’s 50 characters and if you add the jail-directory to it, it exceeds Freenas’ directory-length limit of 88 characters, so you have to change this. Open up the Transmission-settings in the Plugins-tab of Freenas and edit the “Watch Directory” to “/media/torrentfiles” and the Download-Directory to “/media/downloads”.

Lead #2

I found this thread that sounds like your issue, titled: "plugins wont start, in openpam_check_desc_owner_perms(): /etc/pam.d/su: insecure ownership or permis...".

This thread seemed to conclude with there was a permissions problem with /etc/pam.d/*. Changing the permissions to 755, applied to /etc/pam.d/* was reported to fix the issue.

  • The settings in the GUI affect the behaviour when transmission has started, but they should not prevent it from starting. Furthermore, there is no such concept of a chrooted jail. Either you use chroot or a jail (which is the only supported variant on FreeNAS). – Marco Jan 27 '14 at 22:05
  • You can't use Transmission in a chroot on FreeNAS. You have to install it in a jail. Either by using a manual jail install or the plugin mechanism, which also uses jails. Chroot environments are not supported in FreeNAS, only jails. – Marco Jan 27 '14 at 22:19
  • @Marco - OK, I've edited the post removing the references to chroot, it now says just jail. Also added another lead to a solution. – slm Jan 27 '14 at 22:20
  • @Marco - fixed URL, thanks for keeping me honest 8-) – slm Jan 27 '14 at 22:26
  • @Marco - also I've always heard it referred to as a chroot jail: en.wikipedia.org/wiki/Chroot. Wikipedia also has that phrasing. I understand the distinction you're making with splitting those apart, but when I wrote "chrooted jail" I meant the way it's used in theWikipedia article, though I think when I said "chrooted jail" you took that as a verb, when I meant it as a noun in "chroot jail". – slm Jan 27 '14 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.