2

Since I've been using Debian with GNOME 3.4.2 (default version upon installation), I've always used the dconf editor to change the delete accel back to the normal delete instead of <ctrl>delete, but this time it's going wrong - It just doesn't want to stay as delete once I close Nautilus.

Here are the steps I take:

  1. Open Nautilus and move to a file I want to delete.
  2. I click on the file.
  3. I open dconf-editor from Applications -> System Tools -> dconf Editor
  4. Make my way to org -> gnome -> desktop -> interface.
  5. Enable "can_change_accels"
  6. Go back to Nautilus and click on the edit menu and hover over "Move to Trash"
  7. I hit my delete key twice so that the new accel will be the delete key.
  8. Go back to the dconf editor and unselect "can_change_accels"
  9. Close dconf editor and Nautilus.

Once I open Nautilus again, the accel is back to <ctrl>delete and I can't figure out why. I've done this many times, and usually if it doesn't work the first time, after a couple of tries it'll finally stay set, but this time, no dice.

This is a brand new install of Debian that I completed literally about an hour ago, using the default ftp.us.debian.org mirror (if that matters at all).

I even tried going to /home/user/.gnome2/accels and editing the file nautilus there. Saved it, reboot, no change whatsoever.

Does anybody have a solution for this? It's driving me nuts.

Duplicate question: https://unix.stackexchange.com/questions/57853/del-accel-reseted-in-every-boot-debian-testing-nautilus (I know it's bad form to ask a question again if there's already one open, but it was asked in 2011, but was never answered, so I figured it'd be okay to bring up again.)

1

I think you can do it without having to resort to dconf-editor now. Make the following changes directly to Nautilus' keyboard accelerators, located here:

$ vim ~/.config/nautilus/accels

Then replace this line:

; (gtk_accel_path "<Actions>/DirViewActions/Trash" "<Primary>Delete")

by this one:

(gtk_accel_path "<Actions>/DirViewActions/Trash" "Delete")

Then restart Nautilus:

$ nautilus -q
-or-
$ killall nautilus

References

  • ~/.config/nautilus/accels doesn't seem to exist, but I see the same line in ~/.gnome2/accels/nautilus, which I tried already, but no-go. Does Nautilus require a restart before it'll become effective? – user57729 Jan 27 '14 at 14:49
  • Edit answered the question above, one moment. – user57729 Jan 27 '14 at 14:50
  • @user57729 - yes, I just added that to my A. – slm Jan 27 '14 at 14:50
  • 1
    Aha! I see what I did wrong the first time. I forgot to remove the semi-colon that started the line before saving it, thus it wasn't activating the line. This worked perfectly! I'll stick to this from now on instead of using dconf-editor. Thanks so much, @slm! Marked as answer. :D – user57729 Jan 27 '14 at 14:55
  • 1
    Just a note before I head off - The file (on my personal system) was located at ~/.gnome2/accels/nautilus, not the one mentioned in the answer. This may not be the same for everyone, but just in case someone can't find the file located where the answer says, also try this location. – user57729 Jan 27 '14 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.