1

This question already has an answer here:

I have a raspberry pi plugged into my router at home, running raspbian. Before I left for work I:

  • Configured the router to forward ports 80 and 22 to the pi
  • Configured dyndns

This all works, and I can access the pi using http and ssh. The problem is, I forgot to forward another port that I want to use! What I want to do is connect from the pi to my home router's web interface to forward the other port. The router interface is awful: heavy and graphical, and uses javascript. What should I do?

marked as duplicate by slm, Anthon, rahmu, Zelda, jasonwryan Jan 27 '14 at 18:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • try lynx or use ssh proxy forward. – Kiwy Jan 27 '14 at 10:42
  • lynx: To view the Web interface of your device, JavaScript must be supported and enabled on your browser! Please enable scripting and refresh your browser. – Tom Medley Jan 27 '14 at 10:47
3

Setting up an SSH tunnel worked just fine. From work:

ssh -L 8080:192.168.1.254:80 <pi>

Then connecting to localhost:8080 from my browser.

Not the answer you're looking for? Browse other questions tagged or ask your own question.