5

I tried to install 3d effect on my Debian Wheezy using command

$ apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-gnome compiz-gtk

But it gives the following

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package compiz is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'compiz' has no installation candidate
E: Unable to locate package compizconfig-settings-manager
E: Unable to locate package compiz-fusion-plugins-main
E: Unable to locate package compiz-gnome
E: Unable to locate package compiz-gtk

What should I do now?

  • You can probably install it on wheezy from squeeze if you really want to. At the worst you should be able to recompile the sources on wheezy. – Faheem Mitha Jan 27 '14 at 11:58
  • @FaheemMitha Thanks. Could you please show me how? Reply as an answer if you wish. – zhangwfjh Jan 27 '14 at 13:15
  • 1
    I don't know how well compiz can work with gnome3 since gnome3 itself comes with a compositing window manager. Also, compiz development has stopped which is probably why it's been removed from the Debian repos. However, a lot of compiz's functionality is natively available in gnome3. Anything in particular you were looking for? – terdon Jan 27 '14 at 15:46
  • @zhangwfjh After somewhat extraordinary efforts, I managed to build compiz on wheezy. However, I then made the mistake of running it. It trashed my desktop to the extent KDE stopped responding normally and I could not focus on any window to write anything. Fortunately, I was still able to get to a terminal and so was able to reboot. The upshot is that I can write down a sketch of what is involved, but you will probably have difficulty in building it yourself. Also, it will probably not work correctly, though maybe it will work Ok on Gnome, I dunno. – Faheem Mitha Jan 27 '14 at 17:04
  • If you are using amd64 I could also upload my binaries somewhere so you could get them. – Faheem Mitha Jan 27 '14 at 17:05
3

(Google debian compiz.)

Debian Package Tracking System :: http://packages.qa.debian.org/c/compiz.html

It was removed post squeeze as "buggy, and unmaintained".

| improve this answer | |
  • Well, so I have to wait to update? – zhangwfjh Jan 27 '14 at 10:37
  • Beyond debian 6, it does not exist. Unless someone steps up to be the debian maintainer, it will not be re-added to the pool. – Ricky Beam Jan 27 '14 at 10:39
-1

Try,sudo apt-get update

then retry the installation.

I had the same problem and it worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.