1

I want to install Android SDK, so I manually installed Java JDK 7u51, downloaded SDK ADT bundle for Linux x64, and tried to run it. When I run android, the SDK manager windows hangs halfway through the initial downloading process every time. Opening it with the terminal gives me

Error in `java': malloc(): memory corruption: 0x00007ffcd06de5b0

before it hangs. Any idea how to solve this? I am on Linux Mint x64 KDE.
What I did was:

  1. Download Java SE JDK 7u51 (tar.gz format) from their site.
  2. Extract content to /usr/lib/jvm/
  3. Run sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_51/jre/bin/java 1
  4. cd /usr/bin
  5. sudo ln -s /usr/lib/jvm/jdk1.6.0_XX/bin/javac
  6. sudo ln -s /usr/lib/jvm/jdk1.6.0_XX/bin/jar
  7. sudo ln -s /usr/lib/jvm/jdk1.6.0_XX/bin/javadoc
  8. Download SDK ADT bundle for Linux x64
  9. Extract it under /home/username/Android
  10. Run android in tools folder.

EDIT
developer.android.com said I should run eclipse to setup the ADT bundle. When I did that in terminal, I got a different error:

Error in `/usr/bin/java': double free or corruption (!prev): 0x00007fbb08816b30

Is there something wrong with my Java then?

EDIT2
I've reinstalled Linux, and ONLY ran sudo apt-get update && sudo apt-get dist-upgrade. Didn't install a new Java. It's using OpenJDK Java1.0.7_51 now, and when I run "android" it still give me the same error!

Error in `java': malloc(): memory corruption: 0x00007fd0d4797150

Although the code is slightly different. What gives?

closed as off-topic by Jeff Schaller, G-Man, Stephen Rauch, Satō Katsura, Anthon Oct 5 '17 at 5:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, G-Man, Stephen Rauch, Satō Katsura, Anthon
If this question can be reworded to fit the rules in the help center, please edit the question.

  • your link is /usr/lib/jvm/jdk1.6.0_XX/bin/javac and you told us you install version jdk1.7.0_51 ? Are you sure ? – Kiwy Jan 27 '14 at 9:03
  • Yes. It's version 1.7.0-b13. The latest when I downloaded it a few days ago. Ah sorry, I copied that jdk1.6.0_XX from a guide I followed (it's quite old). I used jdk1.7.0_51 instead. – Djalaal Jan 29 '14 at 5:01
  • VTC as the OP has switched distributions, making this not reproducible. – Jeff Schaller Oct 4 '17 at 23:54
0

It seems that something much deeper than java is wrong here. I'm much too new to Linux to figure out the exact problem, let alone solve it. However, it seems there is some memory leak going on in linux mint itself.

It doesn't matter what Java I run, even if I run the Java that comes with a fresh linux mint install. Also, I've had these issues with my RAM. At seemingly random times (was doing sth else every time), my RAM usage would go through the roof. I usually use about 1.5-2GB, but at these times, within a minute or so, the system uses the full 6GB, and fills up my swap for another 4-7GB (out of 10!) too, before everything calm down again (RAM goes to 2GB and swap to 0.5GB) in an instant.

While I didn't directly solve the problem, I decided (as last resort) to switch to kubuntu instead. And indeed, I've got none of those problems now. Java works, and Android SDK too.

Not the answer you're looking for? Browse other questions tagged or ask your own question.