2

Note: forked of this per recommendation here.


While I got the X keyboard layout right on my own after I fixed that stupid typo, I still can't set the console charset, key map, font map, or whatever you want to call it; even considering all [info] [on] the Arch wiki.

For example, if I click the key for Ç (c cedilla), I get a damn Ä (majuscule A with a trema), Tab completion also gives this wrong non ASCII character on a TTY.

I know the keyboard is right, if I pipe correct UTF-8 characters to a TTY, I get them wrong, and if I do it the other way around, they become right (say, to /dev/pts/0).

I heard the console only has support for 128 (or is it 256?) characters at a time, but those can be set. I tried setting FONT_MAP on /etc/vconsole.conf, with no results. The file is now:

KEYMAP=pt-latin9
FONT=Lat2-Terminus16
FONT_MAP=8859-2

I think would solve the problem are those MAP variables. The worst is that these variables are poorly documented, both in the Arch Wiki, and in the vconsole.conf manual pages:

FONT=, FONT_MAP=, FONT_UNIMAP=
    Configures the console font, the console map and the unicode font map.

How can I set them?

Regarding other methods, I'm a bit confused of how I can apply what is in some of the more advanced articles. So far, I have simply copied /usr/share/kbd/keymaps/i386/qwerty/pt-latin9.map.gz to /usr/local/share/kbd/keymaps/, gunziped it, and read it while scratching my head.

I'm sorry, even though I've had this problem since I have Arch as my system, this is to hard for me to find the solution on my own; so I hope you can help me.

  • Please don't use greetings such as "good evening". When people later read this it won't make much sense. 8-). Though in looking at your logo I finally realized that I recognized it and I think we had this conversation before. So if you feel so inclined, do so, I seem to remember you mentioning it as a cultural thing (perhaps?). But don't get upset if they are later removed. It's a common practice to remove salutations and/or greetings and thanks on SE sites. – slm Jan 26 '14 at 21:30
  • When you say TTY & console do you mean the terminal consoles accessible when you use the key combo Ctrl + Alt + F2, etc., or do you mean the pseudo terminal within say gnome-terminal? – slm Jan 26 '14 at 21:35
  • @slm, I don't usually get upset, and never rollback, unless it's the only thing a user does, just to collect rep (which is not your case, you are 2k+ and gave a good reason, indeed it is an odd greeting :S; I'll refrain from using it). And yes, I'm that guy :) Enough of these matters, I stress TTY (instead of always saying console) because I mean the real terminal, not an emulator, sorry if it is confusing. Should I add a note about that in this question? – JMCF125 Jan 26 '14 at 21:59
  • 1
    In the comments should be enough for now. – slm Jan 26 '14 at 22:35
1

it seems your console is not set to unicode.

what is the ouput of stty? it should say "iutf8"; if not, try running on console stty iutf8 and see if that solves your problem (you may need to reload the font after setting the terminal)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.