5

I have 2 files in /sys/class/backlight/ - acpi_video0 and intel_backlight. intel_backlight is the one which controls my screen brightness (echo/cat), however acpi_video0 is the default.

By default, the service systemd-backlight@acpi_video0.service is enabled which should save/restore brightness at shutdown/startup, but it doesn't work since it points to the wrong file.

When trying to enable systemd-backlight@intel_backlight.service instead, I get this message:

The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).

How do I fix this?

  • Side question: Is it normal to have two files in /sys/class/backlight/? – orschiro Apr 3 '14 at 6:47
  • Don't know if it's normal but I have 2 dirs there on my laptop on default install. – Babken Vardanyan Apr 3 '14 at 10:07
0

It may be that you're just missing the backlight: part of the command:

# systemctl enable systemd-backlight@backlight:intel_backlight.service

You may also need to escape the :, i.e.:

# systemctl enable systemd-backlight@backlight\:intel_backlight.service

Since you have two folders in /sys/class/backlight/, you probably have two graphics cards. The Arch wiki suggests adding one of the following kernel parameters in your bootloader:

acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native
acpi_backlight=none
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.