2

I have a GeForce GTX660 and I'm trying to install the latest nvidia driver to ultimately be able to mine dogecoins with these installation instructions

It says to put my kernel version in my PKGBUILD and nvidia.install file. From uname -r I get 3.12.8-1-ARCH but it can't find /usr/lib/modules/extramodules-3.12.8-1-ARCH/version when I run makepkg -ci but extramodules-3.12-ARCH exists. So I just set it to 3.12-ARCH and installed the package.

cat /proc/driver/nvidia/version gives me the output:

NVRM version: NVIDIA UNIX x86_64 Kernel Module  331.38  Wed Jan  8 19:32:30 PST 2014
GCC version:  gcc version 4.8.2 20131219 (prerelease) (GCC)

However running nvidia-smi gives me:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Running cudaminer gives me: Unable to query CUDA driver version! Is an nVidia driver installed? I also tried running it with the official nvidia-304xx driver but that didn't work either.

Also tried just removing nvidia drivers and installing the official nvidia package with the same result.

2

I was trying to run cudaminer through ssh which is why it couldn't find my video card... I was able to run it locally fine. Stupid me. However, is it possible to run it through ssh?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.