My distro (Trisquel, a modified version of Ubuntu 12.04) comes with a 3.2.0-38 kernel. I recently reinstalled it, and after installing a bunch of updates I found that boot would hang on the splash screen.

Heading into GRUB, I found that there was now a 3.2.0-57 kernel set as the default. I removed the "quiet splash" boot parameters and found the reason boot was hanging: it was detecting two resume devices (named, IIRC, /dm-0 and a random bunch of hex digits and hyphens) and prompting me with "enter the full path name or press Enter to boot the system". But neither of those options worked.

For a few days I was content to hold Shift after the BIOS and scroll to the still-bootable 3.2.0-38. Today I got fed up and removed all three non-working kernels I had installed. Big mistake.

3.2.0-38 now behaves just like the other kernels did. And if I try to edit the boot options, I am prompted for a username and password, after which nothing happens. I am simply returned to the initial GRUB screen. My home partition is encrypted, and I've tried entering both my password and the encryption password, but neither has any effect.

Is there a way to fix this without reinstalling the system? And if not, how can I recover my data (my last backup is a little out of date, and I'm not sure how to recover from an encrypted partition)?

  • 1
    "3.2.0-38 now behaves just like the other kernels did." - Maybe the issue is not located in the kernel, but in the initramfs. When 3.2.0-57 was originally installed, update-initramfs created a suitable initramfs for it (which was broken for some reason), but didn't touch the initramfss of the older kernels so you could still boot with 3.2.0-38. When you removed the newer kernels, update-initramfs` may have regenerated the initramfs of 3.2.0-38 for some reason, thereby breaking it too. – Martin von Wittich Jan 24 '14 at 19:12
  • Try to boot with the noresume or noresume2 option added to the kernel command line, maybe that skips the broken resume stuff. – Martin von Wittich Jan 24 '14 at 19:17
  • I can't edit the command line options. I said that in the post. – HeomoSa Jan 24 '14 at 22:16
  • Oh sorry, must've overlooked that. I think it's pretty strange for a distribution to set a grub password, but apparently Trisquel does that. You'll probably have to use a Live CD to recover from this then. – Martin von Wittich Jan 24 '14 at 22:42
  • noresume worked! How can I make this the default? – HeomoSa Jan 24 '14 at 23:06


  1. Boot from a Live CD, edit grub settings, reboot from disk

  2. Pop out the disk. Put in a USB enclosure or connect a SATA -> USB adaptor. Now plug this disk into another Linux system. Mount the /, fix the failure in grub, put the disk back in your system and off you go.

  • I'm on a live CD right now. How do I edit the GRUB options? – HeomoSa Jan 24 '14 at 22:31
  • Mount /boot from your hard disk. In there you will find a directory called grub. In here is your grub config. You could simply remove the password protection of grub. This should let you edit the command line again. Or you can fix the problem. Like Martin was saying, it may be that it is using an incorrect initrd. – Sean Perry Jan 24 '14 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.