0

This is my first time with RHEL. I am using RHEL 6, 64 bit. I want to update Firefox, so I downloaded firefos for 64 bit.

Here are the files I got:

[root@xilinx firefox]# ls
application.ini     libmozalloc.so    libxul.so
browser             libmozsqlite3.so  mozilla-xremote-client
chrome.manifest     libnspr4.so       omni.ja
components          libnss3.so        platform.ini
crashreporter       libnssckbi.so     plugin-container
crashreporter.ini   libnssdbm3.chk    precomplete
defaults            libnssdbm3.so     removed-files
dependentlibs.list  libnssutil3.so    run-mozilla.sh
dictionaries        libplc4.so        Throbber-small.gif
firefox             libplds4.so       updater
firefox-bin         libsmime3.so      updater.ini
icons               libsoftokn3.chk   update-settings.ini
libfreebl3.chk      libsoftokn3.so    webapprt
libfreebl3.so       libssl3.so        webapprt-stub

Now to install upade how do I proceed?

Update

Here is what I tried using yum

[root@xilinx firefox]# yum -y install firefox
Loaded plugins: refresh-packagekit, rhnplugin
There was an error parsing the RHN proxy settings.
RHN support will be disabled.
Setting up Install Process
Package firefox-3.6.9-2.el6.x86_64 already installed and latest version
Nothing to do

But actually this installed version is very old. So what is the solution ?

Update 2

Even I tried this:

yum --enablerepo=remi install firefox

But still I failed to update my firefox as can be seen below:

....
.... 
--> Finished Dependency Resolution
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libsmime3.so(NSS_3.15)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libsmime3.so(NSS_3.15)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libnss3.so(NSS_3.12.9)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libnss3.so(NSS_3.12.9)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libnssutil3.so(NSSUTIL_3.13)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libnssutil3.so(NSSUTIL_3.13)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libssl3.so(NSS_3.13)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libssl3.so(NSS_3.13)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libssl3.so(NSS_3.15)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libssl3.so(NSS_3.15)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: nss >= 3.15.3
           Installed: nss-3.12.7-2.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               nss = 3.12.7-2.el6
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libsmime3.so(NSS_3.13)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libsmime3.so(NSS_3.13)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libssl3.so(NSS_3.14)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libssl3.so(NSS_3.14)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libnss3.so(NSS_3.13)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libnss3.so(NSS_3.13)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libjpeg.so.62(LIBJPEG_6.2)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: nspr >= 4.10.2
           Installed: nspr-4.8.6-1.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201009221801.x86_64/6.0)
               nspr = 4.8.6-1.el6
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libssl3.so(NSS_3.13.2)(64bit)
           Available: xulrunner-last-26.0-1.el6.remi.x86_64 (remi)
               libssl3.so(NSS_3.13.2)(64bit)
Error: Package: xulrunner-last-26.0-2.el6.remi.x86_64 (remi)
           Requires: libz.so.1(ZLIB_1.2.0)(64bit)
 You could try using --skip-broken to work around the problem
libstdc++-4.4.6-4.el6.i686 is a duplicate with libstdc++-4.4.4-13.el6.x86_64
1

# yum -y install firefox

If it has an update it will install.

Note

Some packages in distributions servants take to be updated for the last updated software. If firefox says it is updated, this means that the latest version was not yet available in repos.

  • so how do I add the latest version in repos? – gpuguy Jan 24 '14 at 10:31
  • I think the software is officially added by the distribution. – Gileade Oséias Jan 24 '14 at 10:43
  • @gpuguy, the repos are handled by your distribution with software vetted for compatibility with the rest of the system. In "enterprise" distributions like RHEL or SLES (or even Ubuntu LTS) you'll often find "old" versions that contain backports of all sorts of security patches. – vonbrand Jan 24 '14 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.