1

I have the Ubuntu 12.04 LTS for windows installer. I'm trying to install matplotlib on it. From this page it says I need to download the dependencies first using

sudo apt-get build-dep python-matplotlib

But when I do that I get this

me@ubuntu:~/Desktop$ sudo apt-get build-dep python-matplotlib
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'matplotlib' as source package instead of 'python-matplotlib'
E: Unable to find a source package for matplotlib

How can I get rid of this error?

3

Enable Universe repository in software and updates and then run the below commands,

sudo apt-get update
sudo apt-get build-dep python-matplotlib
  • How do I Enable Universe repository in software and updates? – omega Jan 24 '14 at 2:47
  • open software and updates from dash.Then enable the community maintained free and open source softwares(universe) repository. – Avinash Raj Jan 24 '14 at 2:49
  • When I type software, I only get Ubuntu Software Center and when that opens I see no option to enable the universe repo. – omega Jan 24 '14 at 2:50
  • try this sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe" – Avinash Raj Jan 24 '14 at 2:53
  • ok that ran fine – omega Jan 24 '14 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.