0

Works to start and stop but not to restart:

-bash-4.1# service red5 restart
   Shutting down red5:                              [FAILED]

It was all working before had to delete red5 and JDK and reinstall and now this is happening. Have no clue why.

On Linux CentOS 6

1 Answer 1

1

This is typical if you removed the old red5 and did not shut it down before you did so. The old service might not properly shut down anymore and have some resource open (port).

You should see if there is still a red5 executable running using ps even after doing service red5 stop, or if that fails reboot your machine.

3
  • you could also try lsof -i :Port_NUmber_Use_By_red to identify if a process still use the TCP port of the server.
    – Kiwy
    Jan 23, 2014 at 9:03
  • Actually I fixed it but I don't understand why it worked, so perhaps you could explain why. I just restarted service httpd and service mysqld and after mysqld restarted successfully then red5 restarted...strange.
    – cea
    Jan 23, 2014 at 9:26
  • I guess reboot the machine is the same.
    – cea
    Jan 23, 2014 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .