4

I am trying to install Citrix receiver v. 13 on my 64 bit Debian Wheezy. I tried both amd64 as well as i386 packages (in multiarch), but I fail.

i386 version first

The installation looks like this:
root@grzes:/home/ga/Downloads# dpkg -i icaclient_13.0.0.256735_i386.deb 
Selecting previously unselected package icaclient.
(Reading database ... 338506 files and directories currently installed.)
Unpacking icaclient (from icaclient_13.0.0.256735_i386.deb) ...
dpkg: dependency problems prevent configuration of icaclient:
 icaclient depends on libxmu6.
 icaclient depends on libxerces-c3.1.
 icaclient depends on libcurl3 (>= 7.19.1).
 icaclient depends on libwebkit-1.0-2 | libwebkitgtk-1.0-0.

dpkg: error processing icaclient (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...
Errors were encountered while processing:
 icaclient

When I try to fix the problem, I get:

root@grzes:/home/ga/Downloads# apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  glib-networking:i386 libcurl3:i386 libdbus-glib-1-2:i386 libgail18:i386 libhunspell-1.3-0:i386 libproxy0:i386 librtmp0:i386 libsoup2.4-1:i386 libssh2-1:i386 libxerces-c3.1:i386 libxmu6:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libcurl3:i386 libicu48:i386 librtmp0:i386 libssh2-1:i386 libxerces-c3.1:i386 libxmu6:i386
The following packages will be REMOVED:
  enchant icaclient:i386
The following NEW packages will be installed:
  libcurl3:i386 libicu48:i386 librtmp0:i386 libssh2-1:i386 libxerces-c3.1:i386 libxmu6:i386
0 upgraded, 6 newly installed, 2 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 6,560 kB of archives.
After this operation, 3,090 kB of additional disk space will be used.
Do you want to continue [Y/n]?

Basically it is trying to fix the problem by removing the package I am trying to install. Now this might explain a bit why:

root@grzes:/home/ga/Downloads# apt-get install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 icaclient:i386 : Depends: libxmu6:i386 but it is not installed
                  Depends: libxerces-c3.1:i386 but it is not installed
                  Depends: libcurl3:i386 (>= 7.19.1) but it is not installed
                  Depends: libwebkit-1.0-2:i386 but it is not installable or
                           libwebkitgtk-1.0-0:i386 but it is not installed
                  Recommends: hptc-ica-support:i386 but it is not installable
E: Unmet dependencies. Try using -f.

amd64 version

root@grzes:/home/ga/Downloads# dpkg -i icaclient_13.0.0.256735_amd64.deb 
Selecting previously unselected package icaclient.
(Reading database ... 338506 files and directories currently installed.)
Unpacking icaclient (from icaclient_13.0.0.256735_amd64.deb) ...
dpkg: dependency problems prevent configuration of icaclient:
 icaclient depends on libc6-i386 (>= 2.7-1); however:
  Package libc6-i386 is not installed.
 icaclient depends on ia32-libs; however:
  Package ia32-libs is not installed.
 icaclient depends on lib32z1; however:
  Package lib32z1 is not installed.
 icaclient depends on lib32asound2; however:
  Package lib32asound2 is not installed.
 icaclient depends on nspluginwrapper; however:
  Package nspluginwrapper is not installed.

dpkg: error processing icaclient (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...
Errors were encountered while processing:
 icaclient
root@grzes:/home/ga/Downloads# apt-get install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 icaclient : Depends: libc6-i386 (>= 2.7-1) but it is not installed
             Depends: ia32-libs but it is not installed
             Depends: lib32z1 but it is not installed
             Depends: lib32asound2 but it is not installed
             Depends: nspluginwrapper but it is not installable
E: Unmet dependencies. Try using -f.
root@grzes:/home/ga/Downloads# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  ia32-libs lib32asound2 lib32z1 libc6-i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  freeglut3:i386 ia32-libs ia32-libs-i386:i386 lesstif2:i386 lib32asound2 lib32z1 libacl1:i386 libaio1:i386 libaudiofile1:i386 libbsd0:i386 libc6-i386 libcaca0:i386 libcurl3:i386 libdirectfb-1.2-9:i386 libedit2:i386 libesd0:i386
  libfltk1.1:i386 libgdbm3:i386 libjpeg62:i386 liblzo2-2:i386 libncursesw5:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386 libpam0g:i386 libpopt0:i386 librtmp0:i386 libsdl1.2debian:i386 libsigc++-2.0-0c2a:i386
  libslang2:i386 libssh2-1:i386 libstdc++5:i386 libsvga1:i386 libsysfs2:i386 libtdb1:i386 libts-0.0-0:i386 libvorbisfile3:i386 libx86-1:i386 libxaw7:i386 libxcb-render-util0:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386
  odbcinst1debian2:i386 xaw3dg:i386
Suggested packages:
  ia32-libs-gtk ia32-libs-gtk-i386:i386 pulseaudio-esound-compat:i386 libpam-doc:i386
The following packages will be REMOVED:
  icaclient
The following NEW packages will be installed:
  freeglut3:i386 ia32-libs ia32-libs-i386:i386 lesstif2:i386 lib32asound2 lib32z1 libacl1:i386 libaio1:i386 libaudiofile1:i386 libbsd0:i386 libc6-i386 libcaca0:i386 libcurl3:i386 libdirectfb-1.2-9:i386 libedit2:i386 libesd0:i386
  libfltk1.1:i386 libgdbm3:i386 libjpeg62:i386 liblzo2-2:i386 libncursesw5:i386 libnspr4:i386 libnspr4-0d:i386 libnss3:i386 libnss3-1d:i386 libpam0g:i386 libpopt0:i386 librtmp0:i386 libsdl1.2debian:i386 libsigc++-2.0-0c2a:i386
  libslang2:i386 libssh2-1:i386 libstdc++5:i386 libsvga1:i386 libsysfs2:i386 libtdb1:i386 libts-0.0-0:i386 libvorbisfile3:i386 libx86-1:i386 libxaw7:i386 libxcb-render-util0:i386 libxmu6:i386 libxmuu1:i386 libxp6:i386
  odbcinst1debian2:i386 xaw3dg:i386
0 upgraded, 46 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 12.5 MB of archives.
After this operation, 5,949 kB of additional disk space will be used.
Do you want to continue [Y/n]?

QUESTION: How can I install one of these two versions? In the first case I need to install libwebkit-1.0-2:i386 but it seems to conflict with the amd64 version, and in the latter I need nspluginwrapper but it is not in the repositories for some reason.

  • nspluginwrapper is in the repos, but you need to enable contrib. See: wiki.debian.org/… – jordanm Jan 22 '14 at 5:16
  • @jordanm, it was in Squeeze, but it is not anymore now... – Grzenio Jan 22 '14 at 8:36
1

This worked for me and someone else who had this problem, so I documented it and share it with you.
This was tested with Debian 7.4. It may work on older versions of Debian as well, but I have not tested this.

Get the citrix .deb: http://www.citrix.com/downloads/citrix-receiver/linux/
Select the 64-bit .deb installer.

Example filename: icaclient_13.0.0.256735_amd64.deb

sudo dpkg --add-architecture i386

sudo apt-get install ia32-libs ia32-libs-i386 libglib2.0-0:i386 libgtk2.0-0:i386

sudo dpkg --force-all --install icaclient_13.0.0.256735_amd64.deb

sudo cp --verbose /usr/share/ca-certificates/mozilla/* /opt/citrix/icaclient/keystcacerts/

Now try to run a citrix / ica connection. You may to point your browser to wfica in /opt/Citrix/Icaclient/ at the first time.

The following may seem strange, but you are forced to delete Icaclient in order to install the software with apt-get.

cd /opt/Citrix/

sudo cp Icaclient ~/

sudo apt-get -f install

This will delete ica client. Don't worry, just do it.

cd ~/

sudo mv Icaclient /opt/Citrix/

Try to run a citrix session as before.

I tested this with iceweasel, I am positive it will work for firefox as well, but I don't know if it works with chrome or any other browser...

  • 3
    ia32-libs etc. is obsolete for wheezy. You should install the library you actually need. Also, using the dpkg --force-all flag is not a great idea. What error do you get without it? – Faheem Mitha Mar 8 '14 at 21:26
  • I'm on Ubuntu 16.04 and just ran the first and third line (second line encountered the obsolete error). The --force-all flag seems to have fixed my problem, although I have absolutely no idea what damage I may have done to my system :)) Either way, it's working for ICA provided by my school (NYU). – spicypumpkin Sep 6 '17 at 2:54
0

I ran the following;

sudo apt update

sudo apt upgrade - this identified the missing libraries

sudo apt --fix-broken install - this installed the missing libraries

-2

Run:

sudo apt-get update

then install the deb file, will solve the problem. I have tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.