7

I'm trying to install the Debian ISO, debian-live-7.2-amd64-standard.iso into a virtual machine in VirtualBox but it just hangs.

I'm running this version:

$ virtualbox -h
Oracle VM VirtualBox Manager 4.3.6_RPMFusion
(C) 2005-2013 Oracle Corporation
All rights reserved.
7

I'm embarrassed to say this but this one stumped me for a day before I realized what was going on. VirtualBox doesn't really help the situation either, since it never offers you an option to change the architecture so you're left to figure this out on your own. Here's the issue, if you haven't guessed by now.

After going through the wizard to create a VM you'll need to attach the downloaded ISO to your newly created VM. No big deal, this is accessible under the "Storage" menu item under the "Settings" for the new VM. Now start up the VM.

    ss #1

If you select "Live (amd64)" your VM will seemingly hang without any notification of what's gone awry. However if you reboot it and this time select "Live (amd64 failsafe)" you'll get a huge clue as to what's wrong.

    ss #2

Here's where you say "DUH!". So if we change the VM's architecture to 64-bit we should be OK. Here's how.

Changing a VM's architecture to 64-bit

  1. First go back to the main window of VirtualBox, and select "Settings".

                               ss #3

  2. From here you can access the various hardware settings for a given VM. We're going to change the architecture settings to 64-bit, which are under "General".

        ss #4

  3. Now pull down the "Version" pull-down and change it to "Debian (64 bit)".

        ss #5

  4. Now you should be using the correct architecture, 64-bit.

        ss #6

References

  • While the traditional installer would probably suffer from the same issue, debian-live is not the typical method of installing Debian. – jordanm Jan 21 '14 at 3:06
  • @jordanm - it does, this was the one that I had handy. While writing this up, I tried this one too: debian-7.3.0-amd64-netinst.iso. – slm Jan 21 '14 at 4:00
  • 1
    I suspect this is responsible for many problems people have with 64bit images. On the VB version I used, if you create a machine and give it a name that contains "64" in it, then automatically the version switches to 64bit, but this seemingly only works for distributions it "recognizes", and otherwise you do need to set it. – user44370 Jan 21 '14 at 5:37
  • Looks like someone is preparing to (even better) answer Debian question on SE ;-) – Anthon Jan 21 '14 at 8:04
  • @Anthon - maybe.....8-) – slm Jan 21 '14 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.