0

A little time ago, I reported a bug related to Phonon/pulseaudio. For debugging purposes I was told to disable pulseaudio so phonon can use the hardware directly.

So I searched about how to disable pulseaudio on KDE, but only found solutions in the form apt-get purge pulseaudio*, but since I'm not planning on disabling pulseaudio permanently I do not appreciate that solution.

Is there any way to tell Phonon (or the VLC backend I'm using) not to use pulseaudio?

My system:

OS: Debian jessie
Graphical interface: KDE
Phonon backend: VLC

0

Just kill it. From man pulseaudio:

   -k | --kill
          Kill  an  already  running PulseAudio daemon of the calling user
          (Equivalent to sending a SIGTERM).

So, simply open a terminal and run pulseaudio -k.

  • If i do this pulseaudio is just restarted. – Kritzefitz Jan 19 '14 at 17:37
  • @IchUndNichtDu that stops the current pulseaudio process. Of course you have no sound, that's because your system is configured to use pulseaudio. You asked how you can temporarily disable pulseaudio, that's what you did. It might be started again automatically after a few seconds (depends on what programs you have running) that's probably why you see it in pstree. – terdon Jan 19 '14 at 18:13
  • No, my final question was Is there any way to tell Phonon (or the VLC backend I'm using) not to use pulseaudio?, not just to kill pulseaudio and break my sound until it is restarted. Sorry, if the title is misleading. – Kritzefitz Jan 19 '14 at 18:17
  • 1
    @IchUndNichtDu ah, I see. OK, I edited your question's title tomake that clearer. – terdon Jan 19 '14 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.