5

I have installed FreeNAS 9.2amd64 (based on the same FreeBSD version) on a VirtualBox VM. I created users and pool/volume for my data.

In anticipation of installing apache/mysql-server/php5/php-myadmin FreeBSD packages, I read the following docs from the freenas.org site:

So I created a pluginjail to install packages within. I understood FreeNAS packages are managed by pkgng, which works almost the same than pkg_add/pkg_info/pkg_delete etc...

Then I launched the following command (don't mind the package version) from that jail shell:

$ pkg install mysql-server

And I get the following output:

Updating repository catalogue
pkg: PACKAGESITE/digests.txz: No address record      
pkg: No digest falling back on legacy catalog format                            
pkg: PACKAGESITE/repo.txz: No address record

If I go to PACKAGESITE, I can find both digests.txz and repo.txz files.

Does anyone have an idea?

  • PACKAGESITE=pkg.cdn.pcbsd.org/freenas/9.1-RELEASE/amd64 for pkgng doc: wiki.freebsd.org/pkgng – kirly Jan 19 '14 at 13:47
  • The link is for 9.1 while the title says 9.2 . Which one is it? – schaiba Jan 19 '14 at 15:01
  • it's 9.2 version, but there is no plugin folder for that version. That's why I put 9.1 plugins link. I don't think it is the problem. I've tried a lot of repo, I always have the same issue. – kirly Jan 19 '14 at 15:23
  • I think your only option to install things is to just unpack static compiled stuff and run them by hand. As far as I know installing custom things is just not supported on FreeNAS. – Shiki Jul 13 '15 at 10:29
5

You need to install/update your ports catalogue first. Run these commands first:

portsnap fetch update
 portsnap extract

you can then run your:

pkg install mysql55-server (note: it is mysql55-server and not mysql-server)

  • 2
    portsnap: Command not found. – LassePoulsen Apr 28 '15 at 8:01
  • Same problem as @LassePoulsen, how do I get portsnap? – Veridian Sep 22 '15 at 16:23
1

Install a jail and copy the necessary files from there:

cp /mnt/dataset>/jails/<jail-root>/etc/portsnap.conf /etc
cp /mnt/<dataset>/jails/jail-root>/usr/sbin/portsnap /usr/sbin
/usr/sbin/portsnap fetch
-1

Check your /etc/resolv.conf and make sure you have the correct DNS.

  • this was actually very useful as portsnap command looks through domain names for mirrors. thanks @kimo. – user86041 Oct 3 '17 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.