2

This question already has an answer here:

I just installed Debian and now I am trying to set up Steam.

I did the first 2 steps in the 64 bit instructions and also installed ia32-libs.

But when I run the following:

apt-get install libgl1-nvidia-glx:i386

It tells me this:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package libgl1-nvidia-glx

How can I have apt-get locate and install libgl1-nvidia-glx?

marked as duplicate by Stephen Kitt debian May 7 '17 at 18:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You need to enable the i386 arch. Did you do that? dpkg --add-architecture i386. Then run apt-get update. See wiki.debian.org/Multiarch/HOWTO. I assume you installed Debian stable (wheezy). – Faheem Mitha Jan 19 '14 at 8:39
2

First you have to enable multi-arch support:

$ sudo dpkg --add-architecture i386

After that run sudo apt-get update, and then you can install i386 packages.