2

The other day, I reinstalled my operating system (Crunchbang, fork of Debian). For some reason my fan has been running at full speed (and blowing colder-than-room-temperature air) even though I'm using less than 2% of my CPU.

I've been told to try fancontrol, but after running sensors-detect, the only kernel module I need is coretemp, and it's already loaded by default. Running pwmconfig says there are no available interfaces.

I was also told to try CPU governors, but the only ones available (/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors) are performance and powersave, and powersave is already the default.

But today, I ran screenfetch (a program that displays system info), and under CPU, it said Intel Core i5-3230M CPU @ 3.2GHz. The i5-3230 is normally a 2.6GHz processor, but it supports "turbo boost" up to 3.2GHz when the processor is being used heavily. I went back and looked at some screenshots of screenfetch from my previous installs of this OS on the same machine, when the fan was acting normal, and lo and behold, they said 2.6GHz just like they should. Does that mean that the processor is overclocking itself for no reason, and quite possibly causing the fan to stay on full speed all the time? How could I fix this?

enter image description here

1

There are no means to control turbo with Intel ix processors : it is done automatically based on the thermal dissipation room lelt. Few bins are added to frequency ratio depending on the simultaneous usage of cores For instance with the i7-920, 2 bins are added to the nominal coef 21 when 1 core reaches 100 % usage, but only 1 is added when 4 or 3 or 2 cores run top

Linux was not good to estimate frequency, this is why I suggest to try XFreq. It gives frequency details about the Intel processor when running Linux and shows turbo in action

http://code.google.com/p/xfreq/

lm_sensors migth also be a track for your issue : activating temperature montoring using I/O algorithm can drive fans to some high rpm

Thus you can disable lm_sensors, or in your BIOS, set fans to manual, or play with turbo settings and associated such as speedstep. When off, EIST should leave the processor to its factory frequency

CyrIng

  • Welcome to U & L SE. Although, the above link might answer the question, please add the essential parts which you think might answer the question of OP in your answer. This is to ensure that the answer stays even when the link is broken in future :) – Ramesh May 16 '14 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.