I just installed LMDE on a brand new laptop. When I inserted a movie-dvd for the first time, it was loaded not causing any trouble. But since then, there seems to be no automatic mounting of dvds anymore.

Mouting the dvd manually works fine and even when I open a video player - vlc for example - the dvd gets loaded after a short while.

That wouldn't be too much of an issue for me, but since it's about a laptop of a friend of mine - who isn't too experienced when it comes to technical affairs - I'd better fix it for him.

The output of fdisk -l looks alright too.

I know that's only a small amount of information, but I don't really know what's of further interest for you in order to be able to spot the bug.

  • This is probably handled through the desktop environment. Which one are you using? – terdon Jan 18 '14 at 16:29
  • I installed the "mate" version of LMDE; the desktop environment might be xfce though as far as I remember – user43961 Jan 18 '14 at 19:03
  • The MATE is a desktop environment, if you've left the default, you should be running MATE. look through the DE's settings for autoplay settings. Should be there somewhere. – terdon Jan 18 '14 at 19:07
  • Well I don't think that would solve the problem. On the first try (where it worked properly), there the disc was displayed on the desktop; now it's no longer (no, I didn't change the settings what's showing up on the desktop in the meantime). Same thing for the "file" menu in the default video-player: first try -> menu entry for the dvd; second try -> no entry anymore. But as soon as I load the dvd manually in vlc for example, the autoplay get's "triggered" and a second vlc-windows opens up (that's what we checked as the default behaviour) and starts playing the dvd. – user43961 Jan 18 '14 at 21:39

I have the same issue and your question prompted me to try and solve it, thanks!

I found this thread on the LMDE forums that recommends two workarounds. Either you downgrade your gvfs version or you install udisks-glue. In my case, udisks-glue worked like a charm, so I recommend you try it:

$ sudo aptitude install udisks-glue

Once you've installed it, run the program. You will see no output, it just starts a daemon but your DVDs should now be shown on the Desktop. If that works, add udisks-glueto your startup programs to make it start automatically on login.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.