1

Makes good progress for the first half hour or so, then dies at:

cd bsd_amd64_compiler2/product && ./test_gamma
Using java runtime at: /usr/local/openjdk7/jre
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/invoke/AdapterMethodHandle
gmake[4]: *** [product] Error 1
gmake[4]: Leaving directory `/usr/ports/java/openjdk7/work/openjdk/build/bsd-amd64/hotspot/outputdir'
gmake[3]: *** [generic_build2] Error 2
gmake[3]: Leaving directory `/usr/ports/java/openjdk7/work/openjdk/hotspot/make'
gmake[2]: *** [product] Error 2
gmake[2]: Leaving directory `/usr/ports/java/openjdk7/work/openjdk/hotspot/make'
gmake[1]: *** [hotspot-build] Error 2
gmake[1]: Leaving directory `/usr/ports/java/openjdk7/work/openjdk'
gmake: *** [build_product_image] Error 2
*** [do-build] Error code 1

I'm really at a loss. Previous versions built fine. Doing my updates via the portsnap fetch/update then portmaster -a path. OpenJDK, Apache, and Ruby are the only updates of note this time around. Searching only came up with a couple hits (of the "oh, this is broke" followed by "oh it works now" with no explanation on how it was made to work)...

3

I had the exact same problem when updating my ports tree. I could fix this by completely de-installing the existing openjdk port and re-installing it again. It looks like the openjdk port does not compile properly when there is already an jdk installed during compile time.

pkg delete '*jdk*' '*java*'
cd /usr/ports/java/openjdk7 && make install clean
  • 1
    "pkg delete" wouldn't do the removal due to dependencies, but "make deinstall" followed by a "make install clean" worked. – Brian Knoblauch Jan 20 '14 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.