0

I have Debian 7.3 (wheezy) installed on a VM with Mac OS X host. I didn't install UI like GNOME.

Now I installed netatalk (via apt-get) to use AFP to connect my Mac to the VM. It essentially works but I want netatalk to use the default system users (passwd / shadow files) for authentication. I didn't configure anything except this try in the /etc/netatalk/afpd.conf:

- -passwdfile=/etc/passwd/
0

I just solved my problem. I was using the root user, as I didn't want to add new users (it's a local development-test-server which doesn't have to be secure). And the root user is disabled in netatalk.

Now I added another user and it's working fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.