0

I'm running Fedora 20 on my notebook, and recently I removed some of the Gnome session startup apps which (I believe this was the cause) resulted in my ~/.local/share/applications/ directory not being scanned anymore - any changes in this directory don't get populated in Gnome menu.

How can I get this functionality back? I have no idea what Gnome background app is responsible for this.

migrated from serverfault.com Jan 17 '14 at 10:36

This question came from our site for system and network administrators.

  • 2
    Re-installing the apps would likely be a good place to start. – slm Jan 17 '14 at 14:09
  • @slm, I'd never post this if I knew the name of this app. That's the question)) – Osw Jan 19 '14 at 9:06
0

You can configure the programs that gnome runs as the session starts using /usr/bin/gnome-session-properties. This is a GUI program that should let you re-enable whatever you think you have disabled, using checkboxes. (Assuming you haven't completely removed whatever it was from your system!)

The menu items are little text files that can simply be edited. They have a .desktop extension. Here is a link to scripting gnome menu entries.

There are also GUI tools for manipulation of the Gnome menu itself. Alacarte is probably the most widely used. This blog entry gives you a quick introduction. You may need to install this tool: sudo aptitude install alacarte should do it.

Also, if your menu items were created by a previous version of Gnome have a look this forum post, as malformed/outdated entries may exist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.