2

I want to disable the ATI HDMI sound device.

I have nothing connected to it and for some reason, although it isn't the default sound device, it sometimes kicks in and grabs my sound, leaving the real sound device silent.

How can I block the system from using it?

I'm using Fedora 20 with PulseAudio. I don't use any DE, I prefer answer that doesn't include GUI configuration tool.

1

If it has a unique driver, you can blacklist the module.

(Edit: Better Fedora link)

  • It seems that the link you provided is out of date. I have no modprobe.conf file in etc (which is the described method for Fedora). I have tried already to add the module to blcklist file in modprobe.d but that doesn't work. – Dave's tux Jan 17 '14 at 1:26
  • The second link helped me blocking the module. Turns out it didn't work for me because the file must end with .conf. However, both my cards use the same module, so I can't use this method to disable the ATI Sound device. – Dave's tux Jan 18 '14 at 13:38
  • Sorry, man... that's why I had the "if" at the beginning... – Aaron D. Marasco Jan 19 '14 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.