When I have no apps running, or I'm in the activities screen in GNOME shell, the activities bar is maybe 20px high. When I am running an application, this expands to 70px, possibly to fit the 64x64 application icon it uses for the application. Can I make this bar smaller the whole time?

  • Using Minecraft (which has a smaller icon) has confirmed that it is resizing to fit the icons.
    – Macha
    Apr 12, 2011 at 17:53

2 Answers 2


You have to edit the CSS of the gnome shell theme. The default gnome shell CSS file is kept at /usr/share/gnome-shell/theme/ - make sure that to edit the file you have "root" privileges, then edit "gnome-shell.css".

The styling of the panel (or activities bar) is at #panel (just do a search) - the panel expanding is probably due to the effects of font-size & height


Don't know if you ever found an answer to this, but yep, you can. You will need to dive into the CSS of the theme you're using, though (and where that is will depend on your Gnome Shell version and whether you're using a built in or custom theme).

Once you find the CSS file, open it in something like Gedit and find the references to the Activities bar and change whatever settings you want (for your question in particular, you'll want the height setting). There will probably be about two or three places you'll need to find (the "regular" when nothing is running, one when the activities window is open, and one when an app is open). Once you've made your changes, save the file and restart Gnome Shell (alt+F2, r, enter).

Alternatively, you can just install a new Gnome-Shell theme. If you haven't already, install Gnome-Tweak-Tool. Then, you can download your favorite theme and install it from the Gnome-Tweak-Tool.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .