1

I'm trying to get ipython notebook to run on my Debian machine without much success. I've installed ipython and ipython-notebook via apt-get, but when I try to start it up I get the following:

$ ipython notebook
Could not start notebook. Please install ipython-notebook
$ dpkg -l ipython ipython-notebook
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                          Version             Architecture        Description
+++-=============================-===================-===================-===============================================================
ii  ipython                       1.2.1-2             all                 enhanced interactive Python shell
ii  ipython-notebook              1.2.1-2             all                 interactive Python html notebook
$ ipython --debug notebook        
[TerminalIPythonApp] Config changed:
[TerminalIPythonApp] {'TerminalIPythonApp': {'log_level': 10}}
[TerminalIPythonApp] Using existing profile dir: u'/home/eyal/.config/ipython/profile_default'
[TerminalIPythonApp] Searching path [u'/home/eyal', u'/home/eyal/.config/ipython/profile_default'] for config files
[TerminalIPythonApp] Attempting to load config file: ipython_config.py
[TerminalIPythonApp] Config file ipython_config.py not found

[TerminalIPythonApp] Loading IPython extensions...
[TerminalIPythonApp] Loading IPython extension: storemagic
[TerminalIPythonApp] WARNING | File not found: u'notebook'
[TerminalIPythonApp] IPython not interactive...
$ dlocate ipython_config.py   
ipython: /usr/lib/python2.7/dist-  packages/IPython/config/profile/math/ipython_config.py
ipython: /usr/lib/python2.7/dist-packages/IPython/config/profile/pysh/ipython_config.py
ipython: /usr/lib/python2.7/dist-packages/IPython/config/profile/sympy/ipython_config.py
ipython: /usr/lib/python2.7/dist-packages/IPython/config/profile/cluster/ipython_config.py

Note sure where it's looking for notebook or why it's not finding it. What am I missing?

migrated from serverfault.com Jan 16 '14 at 13:15

This question came from our site for system and network administrators.

  • 1
    Is there a reason you are running it using "sudo"? – Teddy Jan 16 '14 at 9:38
  • What Debian version, please? Please list dpkg -l ipython ipython-notebook. – Faheem Mitha Mar 10 '14 at 16:39
  • Hi, I've updated the dpkg command in my original post. I'm using a Debian derivative called Siduction. It's basically Debian's Sid branch. Thank you – oneself Apr 21 '14 at 15:05
  • @oneself if you want someone to see your comment, you need to prefix it with a @ username. – Faheem Mitha Apr 21 '14 at 15:17
  • @oneself To start with it is complaining about not finding ipython_config.py. However, this is in the ipython package. If you have dlocate installed then do dlocate ipython_config.py. Otherwise dpkg -S ipython_config.py. And post the results in the question. Incidentally, any specific reason you are using an obscure Debian derivative? – Faheem Mitha Apr 21 '14 at 15:23
1

Have you, by any chance, installed another version of iPython (for example, through Pip)?

What is the result of type ipython on your system. If that's something else than ipython is /usr/bin/ipython (or an equivalent in your locale, of course), try to run /usr/bin/ipython notebook.

  • Hi, I've since abandoned using notebook, but have recently tried installing it again, and this time it just worked. So, I'm not sure what was the problem. – oneself Dec 26 '14 at 12:22
  • Since ipython-notebook was installed (as you checked with dpkg) and ipython claimed it was not, I can only see two options: either part of ipython-notebook has been removed without removing the package, or you had two different versions of ipython and was not using the one installed via the ipython package. – Pierre Dec 26 '14 at 13:25
0

First, why are you running with sudo?

Try running it as ipython notebook --debug (i.e. the --debug parameter in the end), it works for me in Debian testing.

  • Sorry, I tried sudo on one occasion just to make sure it was not a permissions problem. When I run "ipython notebook --debug" I just get "Could not start notebook. Please install ipython-notebook" with not debug info. – oneself Jan 16 '14 at 18:18
  • It sounds like you don't have ipython notebook installed. Try apt-cache search ipython-notebook to see if you can install it. – Nathanael Farley Nov 14 '14 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.