2

I'm trying to install some packages with yaourt.

For example, when I try to install Google Chrome, I get the following error:

$ yaourt google-chrome
curl error: Couldn't connect to server

I can access to http://aur.archlinux.org but the command fails.

  • 1
    Have you tried both yaourt.org and AURURL="aur.archlinux.org"? Modify AURURL in /etc/yaourtrc – daisy Jan 15 '14 at 5:31
  • yes https://aur.archlinux.org is the default with http://yaourt.org like you suggest dont work – rkmax Jan 15 '14 at 6:51
  • @warl0ck can recommend another package to package and install from AUR – rkmax Jan 15 '14 at 7:33
2
  1. Ping http://aur.archlinux.org

output: PING aur.archlinux.org (78.46.78.247) 56(84) bytes of data. 64 bytes from alderaan.archlinux.org (78.46.78.247): icmp_seq=1 ttl=49 time=373 ms

  1. Edit your hosts file(linux /etc/hosts), add "78.46.78.247 aur.archlinux.org"

Problem solved!

  • do you know why works with this way? – rkmax Jan 20 '14 at 16:48
  • some new linux kernel – Qinsi Jan 22 '14 at 5:36
  • 1
    Sorry, Maybe new linux kernel ipv6 problem, so use hosts file to direct to the correct ipv4 address ;) – Qinsi Jan 22 '14 at 5:47
  • I have tried disabling ipv6 and it seems that everything works – rkmax Jan 22 '14 at 12:42
0

yes it is the solution, same problem in manjaro in jul 2014 https://forum.manjaro.org/index.php?topic=15097.0

I did Ping http://aur.archlinux.org and result other ip

Edit my hosts file /etc/hosts in linux, add 5.9.250.164 aur.archlinux.org and the problem solved!

0

please note that the IP changed from 78.46.78.247 to 5.9.250.164.

So if you're having problems check if you have an entry in your /etc/hosts pointing to the old IP.

If your DNS is working correctly you shouldn't have to add that entry to the file anyways.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.