2

Use case: when USB flash or SD card is plugged in, the filesystem is mounted. It is mounted by gvfsd. But if the filesystem contains files in legacy 8.3 format (like digital cameras often save file names on fs), then the file names are automatically transformed to upper case. So, the files on filesystem appears like FILENAME.JPG.

How to make gvfs automatically mount FAT/VFAT drives so that the file names would appear in lowercase even if they are saved in the 8.3 format?

0

Add shortname=lower to your mount options.

Or at least, that's what worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.