21

I am using Linux Mint 16 Petra cinnamon. The problem I have is that when I drag a window to the top edge of the screen the window only maximizes to the top half of the screen instead of the the entire screen, just like when I hit the maximize button (plus button on the top right side of the screen).

This is what I get. enter image description here

This is what I want to happen. enter image description here

29

Go into System Settings, then into "Window Tiling and Edge Flip" and check the box marked "Maximize, instead of tile, when dragging window to top edge". Tried it on my Linux Mint 16 installation and it worked flawlessly.

  • 4
    Is there any way to extend this to the keyboard shortcuts? I.e. I want <windows> + <up> to maximize instead of snap to the top of the screen. – Jeremy Upsal Jul 26 '16 at 19:57
  • I second this! It's a little thing, but I am sure there would be a flag somewhere to change this default behaviour – Mothermole1 Nov 12 '17 at 0:49
  • Is there no way to configure the keyboard shortcut too? – Anwar Sep 15 '18 at 11:15
  • Note that a 2nd <windows>+<up> press (after the first tiles it) maximizes it to whole screen. – Beni Cherniavsky-Paskin Aug 1 at 10:49

protected by Community Oct 21 '15 at 18:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.