1

I am on Os X and I am rsyncing from a ext3 volume (that I read with osxfuse 2.6.2) to a HFS+ volume. The data I am backupping are ~ 500GB. Sometimes rsync gives the following message:

file has vanished: '/path/to/file'

if I check the file path I find that the file is listed there but then no such file or directory. I would think this is a problem of osxfuse. Sometimes if I run rsync again some more files are transferred, but I always get the same warning regarding other files.

I would think my backup is incomplete, how can I solve this?

1

Those are intermediate files the system creates and removes (might be created before rsync started). The first rsync takes long, so that happens often between start and finish.

You would not miss anything vital (since it is gone anyway), but just do another rsync -a <from> <to> afterwards and that should run much faster, not giving the system much time to (create and) remove files during the rsync.

  • I have looked to the relevant path and they look like regular files, for example like files of scripting I have created in the past. – simona Jan 13 '14 at 8:31
  • Are these removed on the source system? If on the destination system, it might be two rsyncs competing. Have you tried rsync over ssh instead NFS? – Timo Jan 13 '14 at 8:39
  • the ext3 volume and the HFS volume are two external drives. I am transferring data from one drive to the other, and I am not changing anything on the source meanwhile. what I will do next is investigating what happens if I read the ext3 volume from linux – simona Jan 13 '14 at 8:50
  • @simona I did not read HFS correctly, thought that was NFS therefor I suggested using rsync over ssh. – Timo Jan 13 '14 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.