I'm now using the command sudo apt-get install nfs-kernel-server to make my Ubuntu 12.04.2 LTS server support NFS. But it reports this error:

Need to get 559 kB of archives.
After this operation, 1980 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Err http://cn.archive.ubuntu.com/ubuntu/ precise/main libcap2 amd64 1:2.22-1ubuntu3
  Temporary failure resolving 'cn.archive.ubuntu.com'

I tried to ping cn.archive.ubuntu.com, this address cannot be accessed. But I don't think this is the reason, because on my other good Ubuntu machine, I was able to use the command sudo apt-get install smbfs, and it worked. The ping cn.archive.ubuntu.com command also did not work from this machine.

Can anyone tell me why this is not working and how to fix this issue?

  • 1
    Rather than ping, try host to make sure that your computer can resolve the address. If it cannot, you may need to change DNS servers. – DopeGhoti Jan 13 '14 at 1:25
  • I'm able to ping that hostname as well as run the host command. – slm Jan 13 '14 at 1:33
  • Though these errors are on a Rasp. Pi system these workarounds should help: raspberrypi.stackexchange.com/questions/9307/… – slm Jan 13 '14 at 1:36
  • @DopeGhoti.Yes, your solution has just solved my problems.It is the DNS ip setup problems.After I changed it to a right one , problem solved.Thank you. – wuchang Jan 13 '14 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.