2

I have Gtk+3 already installed as it was with the distro. I need to use gtk+2 and glade. How do I use glade with gtk+2 and still have both gtk2 and gtk3 installed on my linux box?

I have Glade 3.12.2 installed and when I save a project then open it in a text file it shows gtk 3 and need for it to say gtk 2 not gtk 3.

2

i use Linux Mint and i've installed 2 Glade:

  • Glade 3.8.0
  • Glade 3.14.2

If i use Glade 3.8.0, after saving a project i get this XML:

<?xml version="1.0" encoding="UTF-8"?>
<interface>
  <requires lib="gtk+" version="2.24"/>
  <!-- interface-naming-policy project-wide -->
  <object class="GtkWindow" id="window1">
    <property name="can_focus">False</property>
    <child>
      <placeholder/>
    </child>
  </object>
</interface>

So, maybe, solution for you is install also Glade 3.8.0

  • Do you know if there is a way to guarantee that glades made for gtk2 will be compatible with gtk3? – user3467349 Apr 25 '15 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.