3

After installing Linux Mint 16, and installing "Workspace grid (2D) and switcher", workspace switching started to work in a cyclic way. If you have many workspaces (4x4 in my case) navigating them in cyclic way feels like solving a Rubik's Cube.

I.e. if you have 2x2 workspaces, pressing Ctrl+Alt+RightArrow moves you to workspace top-right workspace, pressing again moves you to top-left workspace, then top-right, then top-left and so on.

Before version 2.0 pressing Ctl+Alt+RightArrow had taken you to top-right workspace and never moved you again from there.

Is there any way to return to the old behaviour?

2

I'm on Cinnamon 2.0.14 and I seem to have the behavior you describe by default. There's a setting to activate workspace cycling, perhaps you have done so?

Go into Cinnamon Settings => Workspaces and make sure that "Allow cycling through workspaces" is not selected:

enter image description here

  • Wow!! I'll try it tomorrow! (This problem keeps from using Cinnamon 2.0 on my "production" computers). – Adam Ryczkowski Jan 11 '14 at 19:59
  • Yes, it works!! – Adam Ryczkowski Jan 11 '14 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.