1

I'm using duplicity on OS X Mavericks.

If I run my duplicity command, I get the following error:

===== Begin GnuPG log =====
gpg: conversion from `US-ASCII' to `utf-8' failed: Illegal byte sequence
gpg: “0DB243EE”: skipped: public key not found
gpg: [stdin]: encryption failed: public key not found
===== End GnuPG log =====

The strange thing is that the backup command worked until recently.

How can I fix this?

0

I have found the solution. I always ran duplicity with the --encrypt-key=“XXXXXXXX” option. But for some reason I have to run it without "=" and the quotes. The correct syntax is: --encrypt-key XXXXXXXX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.