I installed Debian 7.3 along with Windows 7, on my Acer Travelmate 2480 (1.73-GHz Intel Celeron M, 80GB HDD, 1GB RAM, Mobile Intel 945GM/GU Express graphics). I downloaded Debian CD-1 and checked its MD5 hash,then I created a bootable USB using Unetbootin.

When I chose to boot Debian the execution was stopping at a line that says pcspkr already registered ... aborting, and then I get a black screen and I can only reboot with Alt+Ctrl+Del.

I searched about this issue, and found a solution to add nomodeset at the end of line that starts with linux when I edit the boot commands in Grub using e, this time it worked but Debian was booting only in text mode.

I'm aware that the issue is related to the graphics driver, but I'm new to Linux, so how can I use the text mode to fix this issue? Or is there any other solution?

  • 1
    try logging in on the textual console. then run startx and see if any obvious error messages appear. it will probably tell you to also check /var/log/Xorg.0.log: to do this, type less /var/log/Xorg.0.log. you can type <kbd>q</kbd> to quit and use the arrow keys to scroll.
    – strugee
    Jan 10, 2014 at 16:55
  • @strugee I tried startx and there was no errors but also a command line, but this time the x mouse arrow is showing.
    – Pierre
    Jan 10, 2014 at 17:08
  • @K7AAY My laptop is Acer Travelmate 2480, I had Windows 7 installed, I downloaded Debian CD-1 and checked it's md5 hash and then I created a bootable USB using Unetbootin.
    – Pierre
    Jan 10, 2014 at 19:25
  • @K7AAY I'm not sure, I downloaded the CD-1 from the torrent page.
    – Pierre
    Jan 10, 2014 at 19:39
  • The default Desktop Environment is GNOME 3.4 gnome.org/gnome-3 ( although xfce and KDE are also included) and the default File Manager is Nautilus. wiki.gnome.org/action/show/Apps/…
    – K7AAY
    Jan 31, 2019 at 0:27

2 Answers 2


I learned a lot from this issue, and here's how to fix it, when you install Debian from CD 1 and you don't use a mirror, the base system will be installed only, and the apt sources.list files contains only the cdrom source and the security updates source.

So first we need to add a packages repository to the file /etc/apt/sources.list

in the command line run

nano /etc/apt/sources.list

and add

deb http://ftp.<COUNTRY>.debian.org/debian/ stable main
deb-src http://ftp.<COUNTRY>.debian.org/debian/ stable main

after that we need to run

apt-get update

I chose to install the default environment using tasksel, we need to install aptitude and tasksel so we can install Gnome

apt-get install aptitude tasksel

and then

tasksel install gnome-desktop --new-install

now the gnomw-desktop task will be installed, and then you can run startx to start the environment.

  • I had the same issue and need to check it if I would encounter at later time.
    – Arefe
    Dec 28, 2017 at 9:09

Suggest you uninstall GNOME

Since your GNOME has failed, suggest you uninstall it

sudo apt-get remove libgtk-3-common
sudo apt-get install ppa-purge
sudo ppa-purge ppa:gnome3-team/gnome3
sudo apt-get dist-upgrade
sudo shutdown –r now

then install one desktop environment with one of the below commands:

  • LXDE

    sudo apt-get install task-lxde-desktop
  • XFCE

    sudo apt-get install xfce4 xfce4-goodies

    sudo apt-get install aptitude tasksel && tasksel install gnome-desktop --new-install
  • KDE

    sudo apt-get install aptitude tasksel && sudo aptitude --without-recommends install ~t^standard$ ~t^desktop$ ~t^kde-desktop$

Which? Well, DebianWiki's Desktop How To says GNOME is the default, and here's the excerpt for others:

KDE is of course a renown(ed) heavy alternative.

Xfce is a fast and light alternative, and especially suited if you were using GNOME 2 and find GNOME 3 disappointing.

For older computers, consider using LXDE or Xfce, because they are less resource-hungry than GNOME or KDE.

Me, I find Xfce does all I need to do.

  • Why do you recommend him installing FOUR different desktop environments? One should be enough (in my opinion, XFCE is the best option). More than one will probably confuse him.
    – Ernest A
    Jan 10, 2014 at 20:09
  • @ErnestA Please read the first sentence: ...suggest you install one with one of the below commands.
    – K7AAY
    Jan 10, 2014 at 21:02
  • I tried installing Gnome, I already have aptitude and tasksel, so I tried tasksel install gnome-desktop --new-install but no output at all.
    – Pierre
    Jan 10, 2014 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.