1

Trying to getting the Intel integrated network card driver (Giga PHY Intel I217V) working on Debian (kernel 2.6.32) but I'm having issues.

I've downloaded the driver from the Intel website and completed the following:

Downloaded the source e1000e driver from the Intel Driver Site

$ cd ~/e1000e
$ sudo make
$ sudo make install
$ rmmod e1000e; modprobe e1000e

lspci, dmesg and lsmod shows that the Intel Ethernet is there but it is not showing up in ifconfig -a. There is no eth0

I have tried restarting; resetting the bios but still no network connection.

NB: This is a USB bootable drive; I have a Ubuntu 13.10 bootable driver (kernel version 3.11) that works fine (network card is picked up without having to install Intel drivers). I wanted to know how to fix this in Debian kernel 2.6.32 (32bit)

-1
ifconfig eth xxx 

Assigns an IP address

  • The common (natural) language used on this site is English. The grammar/spelling doesn't have to be perfect. El lenguaje (naturales) común que se utiliza en este sitio es Inglés. La gramática / ortografía no tiene que ser perfecto. – Anthon Mar 8 '14 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.