1

I upgraded a system from openSuSE 12.3 to 13.1 earlier this week. The upgrade trashed the networking and LDAP. The networking I was able to fix by deleting the bad adapter that the upgrade added, then restoring the right values to the good adapter. LDAP settings were also trashed, but putting them back has not helped.

Along the way I also noticed that the winbind startup scripts got removed. I've added them back in, but still no success. Local logins work, but LDAP logins fail, and the domain user directories are showing numbers for IDs instead of user names.

Permissions on those directories appear to be appropriate. Current notes:

  • winbind fails during startup. However, when run manually it comes up fine.
  • wbinfo -t succeeds.
  • wbinfo -a user results in "Could not authenticate user with plaintext password"
  • Attempts to login via ssh throw:

    "pam_winbind(sshd:auth): request wbcLogonUser failed: WBC_ERR_AUTH_ERROR, PAM error: PAM_SYSTEM_ERR (4), NTSTATUS: NT_STATUS_CONNECTION_DISCONNECTED, Error message was: NT_STATUS_CONNECTION_DISCONNECTED" errors

  • I also see periodic apparmor errors like this:

    "kernel: [86545.268317] type=1400 audit(1389282065.400:102): apparmor="DENIED" operation="open" parent=2133 profile="/usr/sbin/winbindd" name="/var/lib/samba/smb_krb5/krb5.conf.DOMAIN" pid=16744 comm="winbindd" requested_mask="r" denied_mask="r" fsuid=0 ouid=0"

I'm guessing that I'm missing some config setting somewhere, but I've wiped out and rebuilt it through yast without any success. Ideas?

1

I'm not sure if apparmor is the cause, but you may disable the profile temporarily and see if it works:

sudo aa-disable /usr/sbin/winbindd

P.S The aa-logprof command will guide you on updating profiles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.