4

I changed my main user's ID from 1000 to 999 and now it no longer shows on the login screen. I expected it not to show, but I also expected the login screen (the default that ships with MATE/Mint 16) to be "smart enough" to show a box where you can manually type in a username if there are no users over 1000 to list. It isn't.

Is there a way to change to a different login theme that will allow a username to be entered (from the command line, because I can't log in graphically!)? Is there a way to make the login screen show a username prompt? Maybe some hidden hotkey combination?

I can use CTRL+ALT+F2 and login and run startx, but the DE response is brutally slow, and it doesn't have the login screen chooser on the menu when MATE is started that way.

  • 1
    Do you not just want to change whatever number is set that governs the displaying of accounts @ login? I believe there is a similar value to lightdm's on Ubuntu. The value there is this: minimum-uid=500. – slm Jan 9 '14 at 13:32
  • 1
    In this case, I want to be able to login using my admin user by entering the un manually, but not show that that user exists to the general public. This is in preparation for LDAP based logins. The ID that is 999 is the local admin. – Nick Jan 9 '14 at 15:05
  • OK, makes sense, I figured you had a reason but I wanted to double check. – slm Jan 9 '14 at 15:43
  • Hit ESC at the login screen, and it will prompt for a username. – maharvey67 Mar 23 at 21:24
3

Well, there are a few things you could try. Log in from the command line and open the file /etc/mdm/mdm.conf:

sudo nano /etc/mdm/mdm.conf

That's the file that controls mdm's (MInt's default login manager) behavior. You could set

IncludeAll=true

to show all users or

Include=nick

to show yours.

Alternatively, you can change the theme settings:

GraphicalTheme=Transparent UserList

You can see available themes with this command:

ls /usr/share/mdm/themes/
  • 1
    Thanks, I will try this when I get to work in an hour or so and post back. Wouldn't` IncludeAll` show all the "junk" users like sshd, news, pulse, etc? – Nick Jan 9 '14 at 12:58
  • @Nick probably but at least you can then log in and fix stuff. Alternatively, include your user explicitly. – terdon Jan 9 '14 at 12:59
  • @terdon - I do not have access to Mint but I found this which might be helpful. Can you confirm this? unix.stackexchange.com/questions/64499/… – slm Jan 9 '14 at 15:50
  • I was able to change the login theme to one that allowed manual user-name entries. Thanks for the help! – Nick Jan 9 '14 at 22:28
  • @slm Mint uses mdm, a fork of gdm but otherwise very similar. The relevant file is /etc/mdm/mdm.conf but the options seem identical. I played with Exclude= and Include= and both worked as expected and as described in the Q you linked to. – terdon Jan 9 '14 at 23:29
0

To get around this ill-designed behavior, go into Settings->Administration->Login Screen, change from HTML to GDM, and then you'll get a login box with more ill-designed behavior, a password prompt but no username. Just hit [enter] in the empty password box and you'll finally get a username prompt. I have not found a better way yet.

0

The GUI method

  1. Click Menu > Administration > Login Window
  2. In the Theme tab select GDM from the Style dropdown box
  3. Select a Theme from the main picklist that doesn't end in "-Userlist"
  4. Click the Close button.

Job done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.