On a new Dell Inspiron 3521, I tried installing Linux. First try was Ubuntu, but couldn't get the WiFi working. After trying all sort of things and commands, some errors started to show. I then installed Fedora to check it out and see if it would pick up the WiFi. But it didn't either.

Now, I want to install some drivers that should fix it. I've extracted a tarball. The directory contains a Makefile, but when I run make, the following error is thrown:

KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/3.11.10-301.fc20.x86_64/build: No such file or directory.  Stop.
make: *** [all] Error 2

Now I tried to see if that build directory exists, and it does, but as a symlink to a directory that does not exist. It points to /usr/src/kernels/3.11.10-301.fc20.x86_64.

In the kernels directory, I only have 3.12.6-300.fc20.x86_64.

  • 1
    Did you install the kernel headers?
    – 41754
    Jan 8, 2014 at 13:55
  • Yes, yum list | grep kernel-headers outputs kernel-headers.x86_64 3.12.6-300.fc20
    – Tim Baas
    Jan 8, 2014 at 14:10
  • Turns out now I'm facing the exact same problem, but with a fc19 virtual machine. Let us hope for an answer.
    – 41754
    Jan 14, 2014 at 12:03

2 Answers 2


Do ln -s /usr/src/kernels/3.12.6-300.fc20.x86_64 /usr/src/kernels/3.11.10-301.fc20.x86_64.

  • Thanks! That is actually what I tried before, but more out of a guess.. make still fails due to implicit declaration of function and dereferencing pointer to incomplete type errors.. I guess that is another problem then?
    – Tim Baas
    Jan 8, 2014 at 14:26
  • Then you did wrong! This is actually the last resource bullet, and not the first way of working around your problem. In fact it may be better to fail at this stage than going through and experience instability later.
    – 41754
    Jan 8, 2014 at 14:30

At least on fedora 20, this resolves the issue for me:

yum -y install kernel-devel-3.11.10-301.fc20.x86_64 kernel-headers-3.11.10-301.fc20.x86_64

If you're explicit with the header install, this solves the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .