12

How do I stop emacs from colouring the text of the file I am editing? I want everything just in plain white. I know that I can load themes, but it's not obvious which theme does what. Can I just disable all the colouring so that when I start emacs up, all the text is always white?

4
  • I have now done this. Commented Jan 7, 2014 at 18:01
  • The syntax highlighting depends on the major mode. text-mode should not involve any syntax highlighting.
    – jordanm
    Commented Jan 7, 2014 at 18:12
  • 1
    Thanks - important for colorblind folks like me for whom the new colors and my background color look nearly identical....
    – nealmcb
    Commented Nov 8, 2020 at 18:53
  • I was looking for "how can I stop Emacs when it's stuck in color highlighting" which is here: superuser.com/questions/641124/…
    – tripleee
    Commented Aug 22, 2023 at 9:26

1 Answer 1

16

Colours are provided by the font-lock minor mode.

To disable colouring in your current buffer, toggle font-lock-mode off with this command:

M-x font-lock-mode

To disable font-lock-mode permanently, add to your init file (~/.emacs):

(global-font-lock-mode 0)

More info is available under Font-Lock in the Gnu Emacs Manual

1
  • 1
    Thanks a lot - what a relief not to have to see those colours again! Commented Jan 7, 2014 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .