1

I want to run a jar file in Linux (CentOS, 32-bit). But the following error occurs. What is the reason?

[root@server ~]# java -jar keygen.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/dgt/jl/App : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.dgt.jl.App. Program will exi

My Java version:

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.14) (rhel-1.42.1.11.14.el5_10-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)

migrated from serverfault.com Jan 7 '14 at 11:14

This question came from our site for system and network administrators.

1

From the error message Unsupported major.minor version 51.0, have you tried to launch the jar with latest edition of java?

(IIRC It should be compiled with Java 1.7, but you run a lower version)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy