I am running Debian Squeeze. I installed and removed Gnome3 and reinstalled Gnome2.x (epic fail and stupidity) and in the process I have lost audio, lspci returns following

# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)   

But lsmod doesn't return any thing.

$ lsmod |grep audio

Any idea what could be wrong?

Here is an update, I tried to install whatever possible package was removed by studying /var/log/dpkg.log. This fixed my other issues like no right click on desktop and blunt looking buttons etc. Now I have everything in order but sound is missing. I don't see sound section in gnome-control-center. Here are some findings:

kumar@debian-box:/$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
kumar@debian-box:/$ lsmod |grep audio
kumar@debian-box:/$ lsmod |grep snd  
kumar@debian-box:/$ lsmod |grep sound
kumar@debian-box:/$ cat alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Last update, I fixed it using sudo modprobe snd-hda-intel, it seems I messed up kernel headers.

  • Please format your code and output properly by indenting it with 4 spaces. – Mikel Apr 7 '11 at 10:49
  • 1
    Does /var/log/dpkg.log say that any audio-related packages were removed? – Mikel Apr 7 '11 at 10:51
  • @Mikel: +1, your comment helped me in fixing another issue with UI, I will continue with my fix, thaks :) – Kumar Apr 7 '11 at 13:47
  • There's no reason lsmod | grep audio should return anything (most sound-related drivers have snd or just a technology or chip designation in their name). If you try to play a sound, do you get any error message (try from the command line to be sure to see any message) or just no sound? If there's no error message, start a mixer and make sure all relevant volume controls are not muted. – Gilles Apr 7 '11 at 20:19
  • @Gilles, thanks for pointing, I knew it but just to eliminate any possibility of a string with audio I did grep audio, you can notice the second one is snd and third one is sound, I am frustrated :-( – Kumar Apr 8 '11 at 4:01

Maybe you removed alsa related packages or you messed up their installation. Since there are no snd_* modules loaded, it's probable that /etc/modprobe.d/alsa-base.conf is wrong or missing. Try reinstalling alsa and reboot:

apt-get --reinstall install alsa-base alsa-oss alsa-utils gstreamer0.10-alsa

Sometimes, upgrading a package, with many dependencies, to a major release version, a lot of those dependencies might be removed and replaced with alternative packages. When downgrading to the previous release, it is not certain that the dependency chain will return to it's original state. Especially the upgraded configuration files.


So, if you have upgraded from another repository than stable, like the experimental one, there is a way to downgrade all your packages to the stable release and hopefully fix all dependencies.

Create a file /etc/apt/preferences and add the following contents:

Package: *
Pin: release a=squeeze
Pin-Priority: 1001

This is called pinning and it will give maximum priority to squeeze packages. Ensure you have squeeze repositories in /etc/apt/sources.list and run

apt-get update
apt-get -d dist-upgrade
apt-get dist-upgrade

This will downgrade every package to stable release. You have to be careful and watch the whole process, as all installation scripts are optimized for upgrading and not downgrading, this means that some packages may try to install in the wrong order. If that cause the downgrade to break, use dpkg --force-all -i /var/cache/apt/archives/<pkgname>.deb to force the installation of any required package, or apt-get -f install when needed and restart the dist-upgrade process.

Remove /etc/apt/preferences at the end.

  • I have /etc/modprobe.d/alsa-base.conf and Reinstallation of gstreamer0.10-alsa is not possible, it cannot be downloaded., other 3 packages are also installed but in any case I will go with your tip and try it, no harm in trying – Kumar Apr 7 '11 at 12:55
  • It didn't help :( – Kumar Apr 7 '11 at 13:09
  • @Kumar, added a small guide for downgrading debian releases. – forcefsck Apr 7 '11 at 20:36
  • +1 for the guide, thanks a ton. But it didn't fix anything for me, 0 upgraded, 0 newly installed, 0 to remove :( – Kumar Apr 8 '11 at 4:08

Maybe you grep wrong sentence? Are you sure that you need 'audio' in modules name to have sound? use modprobe -l | grep sound to get sounds drivers.

  • check my update – Kumar Apr 7 '11 at 18:21
  • Ok you should have snd_hda* modules loaded. There are my list [t0@larch ~]$ lsmod | grep snd | awk -F' ' '{print $1}' snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_hda_codec_hdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc usbcore try to load that modules by modprobe – teZeriusz Apr 7 '11 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.